summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorname2014-02-20 15:50:06 +0100
committername2014-02-20 15:50:06 +0100
commit1a86b77a00c2db5bfaad48f9ad6b55773213ca11 (patch)
treee550d2a1956df9f807629222d75ea1ab2afdea22
downloadaur-1a86b77a00c2db5bfaad48f9ad6b55773213ca11.tar.gz
AUR4 split: Added antichamber
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD67
-rw-r--r--antichamber.changelog9
-rw-r--r--antichamber.desktop10
5 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05e70cda0ebf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = antichamber
+ pkgdesc = A mind-bending psychological exploration game where nothing can be taken for granted
+ pkgver = 1392664980
+ pkgrel = 2
+ url = http://www.antichamber-game.com/
+ changelog = antichamber.changelog
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = unknown
+ makedepends = unzip
+ depends = libvorbis
+ depends = sdl2
+ source = hib://antichamber_1.01_linux_1392664980.sh
+ source = antichamber.desktop
+ source = antichamber.changelog
+ sha256sums = 4973acf3b995ee015ce12908c368acd10db86614e45088a6ccdb53b60e8c235e
+ sha256sums = 5b2a809bc1c70f50fc372571db5048bbc428f893e7e861fac572d622b588d82a
+ sha256sums = SKIP
+
+pkgname = antichamber
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..841a09db2073
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.pkg.*
+*.src.*
+antichamber_*.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8f6a55ebb34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: J0k3r <moebius282 at gmail dot com>
+
+pkgname=antichamber
+pkgver=1392664980
+pkgrel=2
+pkgdesc="A mind-bending psychological exploration game where nothing can be taken for granted"
+url="http://www.antichamber-game.com/"
+license=('unknown')
+arch=('i686' 'x86_64')
+groups=("games")
+_purgelibs=('libogg.so' 'libvorbis.so' 'libvorbisfile.so.3' 'libSDL2-2.0.so.0')
+if [ "$CARCH" = "x86_64" ]; then
+ depends=('lib32-libvorbis' 'lib32-sdl2' ) # 'lib32-sdl2_mixer' not in repo and aur package misnamed & broken ; gperftools only in aur :/
+else
+ depends=('libvorbis' 'sdl2')
+ # _purgelibs+=('libtcmalloc.so.0' 'libSDL2_mixer-2.0.so.0') #gperftools doesn't provide a required symlink; also: 'MinorityMix_SetPosition', could be sdl2_mixer
+fi
+makedepends=('unzip')
+changelog="${pkgname}.changelog"
+_archivename="${pkgname}_1.01_linux_${pkgver}.sh"
+source=("hib://${_archivename}"
+ "${pkgname}.desktop"
+ "${pkgname}.changelog")
+sha256sums=('4973acf3b995ee015ce12908c368acd10db86614e45088a6ccdb53b60e8c235e'
+ '5b2a809bc1c70f50fc372571db5048bbc428f893e7e861fac572d622b588d82a'
+ 'SKIP')
+PKGEXT=".pkg.tar"
+
+
+# You can download the Humble Indie Bundle file manually, or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, to use hib-dlagent to download files set something like this in
+# your makepkg.conf (change/add -k and add -u/-p to your needs):
+# DLAGENTS=('hib::/usr/bin/hib-dlagent -k 1a2b3c -o %o $(echo %u | cut -c 7-)')
+#
+# To auto-search through a directory containing Humble Bundle downloads, you
+# could set:
+# DLAGENTS=('hib::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+
+package()
+{
+ mkdir -p "${pkgdir}/opt/${pkgname}/"
+
+# unzip is stupid..
+ unzip -qq "${srcdir}/${_archivename}" -d "${pkgdir}/opt/tmp/" 'data/*' || true
+
+ # seems like flibit has a new directory structure, stuff is now in folders related to the target arch (noarch, x86 here). we need to 'unpack' those
+ mv "${pkgdir}/opt/tmp/data/"*/* "${pkgdir}/opt/${pkgname}/"
+ rm -r "${pkgdir}/opt/tmp/"
+
+ for i in "${_purgelibs[@]}"; do
+ rm "${pkgdir}/opt/${pkgname}/Binaries/Linux/lib/${i}"
+ done
+
+# patching the included startup script so it supports being symlinked
+ sed -i -e 's|$(dirname "$0")|$(dirname \"$(readlink -f \"$0\")\")|' "${pkgdir}/opt/${pkgname}/${pkgname^}.sh"
+
+ install -d "${pkgdir}/usr/bin/"
+ ln -s "/opt/${pkgname}/${pkgname^}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${pkgdir}/opt/${pkgname}/AntichamberIcon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
+
diff --git a/antichamber.changelog b/antichamber.changelog
new file mode 100644
index 000000000000..f16a9200901b
--- /dev/null
+++ b/antichamber.changelog
@@ -0,0 +1,9 @@
+2013-02-18 | J0k3r <moebius282@gmail.com>
+
+ * antichamber-1392664980-1:
+ - Inital Release ( antichamber_1.01_linux_1392664980.sh )
+
+2013-02-19 | J0k3r <moebius282@gmail.com>
+
+ * antichamber-1392664980-2:
+ - Fixed 32-bit build. Using provided 'libtcmalloc.so.0' and 'libSDL2_mixer-2.0.so.0' \ No newline at end of file
diff --git a/antichamber.desktop b/antichamber.desktop
new file mode 100644
index 000000000000..7631de8bff38
--- /dev/null
+++ b/antichamber.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Antichamber
+Comment=A mind-bending psychological exploration game where nothing can be taken for granted
+Icon=antichamber
+Exec=antichamber
+Categories=Game;
+