summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Price2021-06-23 23:22:34 -0700
committerChristopher Price2021-06-23 23:22:34 -0700
commit1a8ffbaca6036f282d25225171e619abc01a93be (patch)
treed1ccf8dadd823e0ae728ac617077397fe5fe5544
parentaaf3a51f8a52ea0b417eabc46752fbe07c6be9dc (diff)
downloadaur-1a8ffbaca6036f282d25225171e619abc01a93be.tar.gz
Make downloaded source filename unique
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1f0ca62f7fe..72ee1bba40d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = google-drive-ocamlfuse
pkgdesc = FUSE-based file system backed by Google Drive, written in OCaml
pkgver = 0.7.26
- pkgrel = 1
+ pkgrel = 2
url = https://astrada.github.io/google-drive-ocamlfuse/
arch = x86_64
arch = i686
@@ -14,7 +14,7 @@ pkgbase = google-drive-ocamlfuse
makedepends = dune
makedepends = ocaml-ounit
options = staticlibs
- source = https://github.com/astrada/google-drive-ocamlfuse/archive/v0.7.26.tar.gz
+ source = google-drive-ocamlfuse-0.7.26.tar.gz::https://github.com/astrada/google-drive-ocamlfuse/archive/v0.7.26.tar.gz
sha256sums = 273b1bbc5fc8b98bdee659bd2e5e67ec35cdbd2a75a5f353ba58533cff937890
pkgname = google-drive-ocamlfuse
diff --git a/PKGBUILD b/PKGBUILD
index d341f3cbe556..3035db3d08bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Moritz Lipp <mlq@pwmt.org>
pkgname=google-drive-ocamlfuse
pkgver=0.7.26
-pkgrel=1
+pkgrel=2
pkgdesc='FUSE-based file system backed by Google Drive, written in OCaml'
arch=('x86_64' 'i686')
url='https://astrada.github.io/google-drive-ocamlfuse/'
@@ -19,11 +19,11 @@ makedepends=(
'ocaml-ounit'
)
options=('staticlibs')
-source=("https://github.com/astrada/$pkgname/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/astrada/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('273b1bbc5fc8b98bdee659bd2e5e67ec35cdbd2a75a5f353ba58533cff937890')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd ${srcdir}/${pkgname}-${pkgver}
# Old method requires ocamlbuild instead of jbuilder/dune
#ocaml setup.ml -configure --prefix /usr --destdir "$pkgdir" --exec-prefix "/usr"
@@ -40,7 +40,7 @@ build() {
#}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd ${srcdir}/${pkgname}-${pkgver}
#export OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
#ocaml setup.ml -install