summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlaï Deutel2020-05-18 20:18:58 -0700
committerIlaï Deutel2020-05-18 20:18:58 -0700
commit1a9a35a85dd19b89c138a386d33887bcc04e0f2a (patch)
tree6c52c62af5f13b8d13b61fd8c9eec6d6ff8aaddf
parent7dfd1521ead239cb39f71bbf2820ebee069e5573 (diff)
downloadaur-1a9a35a85dd19b89c138a386d33887bcc04e0f2a.tar.gz
Enable PIE compilation for SCC
upgpkg: scc 2.12.0-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43fd92d97b82..72bab9b3dca0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scc
pkgdesc = Sloc, Cloc and Code: a very fast accurate code counter with complexity calculations and COCOMO estimates written in pure Go
pkgver = 2.12.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/boyter/scc
arch = x86_64
arch = i386
diff --git a/PKGBUILD b/PKGBUILD
index db1922decbb7..7cba0860ed3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=scc
pkgver=2.12.0
-pkgrel=1
+pkgrel=2
pkgdesc='Sloc, Cloc and Code: a very fast accurate code counter with complexity calculations and COCOMO estimates written in pure Go'
arch=('x86_64' 'i386')
url="https://github.com/boyter/scc"
@@ -27,6 +27,7 @@ build() {
cd "$GOPATH/src/github.com/boyter/$pkgname"
go install \
-trimpath \
+ -buildmode=pie \
-ldflags "-extldflags $LDFLAGS" \
-v ./...
}