summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2019-10-20 15:17:33 +0200
committerMort Yao2019-10-20 15:17:33 +0200
commit1aba9c9fece691d09e6c53f1181d0e1728d6552d (patch)
tree0a5ea89b2928a4305a7e83ea668e8ad98c7ecdde
parent12c7dceb26379befd2be201e872c531716fba189 (diff)
downloadaur-1aba9c9fece691d09e6c53f1181d0e1728d6552d.tar.gz
ocaml-batteries-git 20191001-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--fix-ocaml-4.08.patch12
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6348d3835d0..a429088fa236 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Feb 13 03:02:42 UTC 2018
+# Sun Oct 20 13:16:44 UTC 2019
pkgbase = ocaml-batteries-git
pkgdesc = Batteries Included for OCaml
- pkgver = 20180122
+ pkgver = 20191001
pkgrel = 1
url = http://github.com/ocaml-batteries-team/batteries-included
install = ocaml-batteries-git.install
@@ -16,7 +16,9 @@ pkgbase = ocaml-batteries-git
provides = ocaml-batteries
conflicts = ocaml-batteries
source = ocaml-batteries-git::git://github.com/ocaml-batteries-team/batteries-included.git
+ source = fix-ocaml-4.08.patch
md5sums = SKIP
+ md5sums = 04ed53e7e68034f975fc21c00d5b6572
pkgname = ocaml-batteries-git
diff --git a/PKGBUILD b/PKGBUILD
index 6ef72627f40c..b7a4d769f734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
pkgname=ocaml-batteries-git
-pkgver=20180122
+pkgver=20191001
pkgrel=1
pkgdesc="Batteries Included for OCaml"
arch=('i686' 'x86_64')
@@ -13,8 +13,10 @@ makedepends=('ocamlbuild')
optdepends=('ocaml-bisect')
provides=('ocaml-batteries')
conflicts=('ocaml-batteries')
-source=("${pkgname}::git://github.com/ocaml-batteries-team/batteries-included.git")
-md5sums=('SKIP')
+source=("${pkgname}::git://github.com/ocaml-batteries-team/batteries-included.git"
+ fix-ocaml-4.08.patch)
+md5sums=('SKIP'
+ '04ed53e7e68034f975fc21c00d5b6572')
install=$pkgname.install
pkgver () {
@@ -22,6 +24,12 @@ pkgver () {
git log -1 --pretty=format:%cd --date=short | sed 's/-//g'
}
+prepare() {
+ cd "$pkgname"
+
+ patch -Np1 -i ../fix-ocaml-4.08.patch
+}
+
build () {
cd "$pkgname"
diff --git a/fix-ocaml-4.08.patch b/fix-ocaml-4.08.patch
new file mode 100644
index 000000000000..d740af4aa116
--- /dev/null
+++ b/fix-ocaml-4.08.patch
@@ -0,0 +1,12 @@
+
+--- ocaml-batteries-git/src/batteries.mlv 2019-10-20 14:54:12.758195004 +0200
++++ ocaml-batteries-git/src/batteries.mlv 2019-10-20 14:54:28.091527675 +0200
+@@ -34,7 +34,7 @@
+ module Random = Random
+ module Scanf = Scanf
+ module Set = Set
+- module Sort = Sort
++##V<4.8## module Sort = Sort
+ module Stack = Stack
+ module StdLabels = StdLabels
+ module Stream = Stream