summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-08-23 13:47:15 +0200
committersmls2015-08-23 13:52:58 +0200
commit1b14183f6fc1ce5af9ecec5ec8ecfbbf81693b74 (patch)
tree69a032b82821fcf2179c75566c35c816107f944f
parentcc89d411891f19d844f95dd3e126c09cde151acd (diff)
downloadaur-1b14183f6fc1ce5af9ecec5ec8ecfbbf81693b74.tar.gz
general clean-up
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD44
2 files changed, 20 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 843264e58c4b..48b3e72636a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,6 @@ pkgbase = libtiff3
optdepends = freeglut: for using tiffgt
provides = libtiff3
provides = libtiff4
- options = !libtool
source = http://download.osgeo.org/libtiff/tiff-3.9.7.tar.gz
sha256sums = f5d64dd4ce61c55f5e9f6dc3920fbe5a41e02c2e607da7117a35eb5c320cef6a
diff --git a/PKGBUILD b/PKGBUILD
index 118499782ed2..c942e28ed23f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,38 +14,34 @@ license=('custom')
depends=('libjpeg' 'zlib' 'libtiff')
makedepends=('freeglut')
optdepends=('freeglut: for using tiffgt')
-source=(http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz)
+source=("http://download.osgeo.org/libtiff/tiff-$pkgver.tar.gz")
sha256sums=('f5d64dd4ce61c55f5e9f6dc3920fbe5a41e02c2e607da7117a35eb5c320cef6a')
-options=('!libtool')
provides=('libtiff3' 'libtiff4')
build() {
- cd "${srcdir}/tiff-${pkgver}"
- ./configure --prefix=/usr
- make
+ cd tiff-$pkgver
+ ./configure --prefix=/usr
+ make
}
check() {
- cd "${srcdir}/tiff-${pkgver}"
- make check
+ cd tiff-$pkgver
+ make check
}
package() {
- cd "${srcdir}/tiff-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # Cleaning binaries and headers
- rm -rvf ${pkgdir}/usr/bin
- rm -rvf ${pkgdir}/usr/include
- # Remove documentation
- rm -rvf ${pkgdir}/usr/share/man
- rm -rvf ${pkgdir}/usr/share/doc
- # Fix libraries
- cd ${pkgdir}/usr/lib/
- # Remove main library, this is supplied by libtiff package
- rm -vf libtiff.{a,so} libtiffxx.{a,so}
- # http://www.asmail.be/msg0055009514.html
- ln -svf libtiff.so.${pkgver} libtiff.so.4
- ln -svf libtiffxx.so.${pkgver} libtiffxx.so.4
+ cd tiff-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ # Remove files which are already installed by the libtiff package
+ rm -f "$pkgdir"/usr/lib/libtiff{,xx}.{a,so}
+ rm -rf "$pkgdir"/usr/bin
+ rm -rf "$pkgdir"/usr/include
+ rm -rf "$pkgdir"/usr/share/man
+ rm -rf "$pkgdir"/usr/share/doc
+
+ # see http://www.asmail.be/msg0055009514.html
+ ln -sf libtiff.so.$pkgver "$pkgdir"/usr/lib/libtiff.so.4
+ ln -sf libtiffxx.so.$pkgver "$pkgdir"/usr/lib/libtiffxx.so.4
}
-