summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Lopes2021-05-10 16:25:04 -0300
committerFrancisco Lopes2021-05-10 16:25:04 -0300
commit1b1c6dfc8bfedae5f6d850caa90e02315c59a135 (patch)
tree675608765085601c292800b641058f5a94c6da82
parent10ac3c6fbfbafde79805836b30400f52df1e937a (diff)
downloadaur-1b1c6dfc8bfedae5f6d850caa90e02315c59a135.tar.gz
Fix due to change in GitLab asset's urls
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a94dc1c772c1..e123ab373490 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = interception-xswitch
pkgdesc = xswitch: an Interception Tools tool to redirect stdin to a muxer if a X window matches
pkgver = 0.1.6
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/interception/linux/plugins/xswitch
arch = x86_64
license = MIT
@@ -12,8 +12,8 @@ pkgbase = interception-xswitch
depends = glibc
depends = libx11
depends = libxmu
- source = interception-xswitch.tar.gz::https://gitlab.com/interception/linux/plugins/xswitch/repository/archive.tar.gz?ref=v0.1.6
- sha256sums = d0e0abf370d8eba7af95c8f062a96cabda5cf2affa438e831173ef0e89fb0b68
+ source = https://gitlab.com/interception/linux/plugins/xswitch/-/archive/v0.1.6/xswitch-v0.1.6.tar.gz
+ sha256sums = 08b6a8c6e0bc901899ba4bdcf4612492a3f94459f86159a6ad3eb3e7513af2b6
pkgname = interception-xswitch
diff --git a/PKGBUILD b/PKGBUILD
index 6b7d84345e3b..191dea4015a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Francisco Lopes <francisco+interception@nosubstance.me>
pkgname=interception-xswitch
pkgver=0.1.6
-pkgrel=2
+pkgrel=3
pkgdesc='xswitch: an Interception Tools tool to redirect stdin to a muxer if a X window matches'
arch=('x86_64')
license=('MIT')
url='https://gitlab.com/interception/linux/plugins/xswitch'
depends=('interception-tools' 'glibc' 'libx11' 'libxmu')
makedepends=('boost' 'cmake' 'gcc')
-source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/xswitch/repository/archive.tar.gz?ref=v${pkgver}")
-sha256sums=('d0e0abf370d8eba7af95c8f062a96cabda5cf2affa438e831173ef0e89fb0b68')
+source=("https://gitlab.com/interception/linux/plugins/xswitch/-/archive/v${pkgver}/xswitch-v${pkgver}.tar.gz")
+sha256sums=('08b6a8c6e0bc901899ba4bdcf4612492a3f94459f86159a6ad3eb3e7513af2b6')
build() {
- cd ${srcdir}/xswitch-v${pkgver}-*
+ cd ${srcdir}/xswitch-v${pkgver}
cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
cmake --build build
}
package() {
- cd ${srcdir}/xswitch-v${pkgver}-*/build
+ cd ${srcdir}/xswitch-v${pkgver}/build
make DESTDIR="$pkgdir/" install