summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReventlov2015-06-08 22:45:01 +0200
committerReventlov2015-06-08 22:45:01 +0200
commit1b2a96455e319a7fea96bec84f4274bef780a716 (patch)
treea0d917f7b6ea73a694d8d5f0c405934686669f43
downloadaur-1b2a96455e319a7fea96bec84f4274bef780a716.tar.gz
initial version
-rw-r--r--.SRCINFO31
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD38
-rw-r--r--isso.conf6
-rw-r--r--isso.install10
-rw-r--r--isso.service10
6 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2409f04c2a88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = isso
+ pkgdesc = A commenting python server similar to disqus
+ pkgver = 0.9.9
+ pkgrel = 1
+ url = http://posativ.org/isso/
+ install = isso.install
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python
+ depends = python-werkzeug
+ depends = python-html5lib
+ depends = python-misaka
+ depends = python-itsdangerous
+ depends = python-six
+ depends = sqlite
+ depends = python-setuptools
+ backup = etc/conf.d/isso
+ source = https://pypi.python.org/packages/source/i/isso/isso-0.9.9.tar.gz
+ source = https://pypi.python.org/packages/source/i/isso/isso-0.9.9.tar.gz.asc
+ source = isso.service
+ source = isso.conf
+ source = LICENSE
+ sha1sums = b6fa8b1c05e1edcd2089c1512ce6f8e0cd2acdaa
+ sha1sums = SKIP
+ sha1sums = f3ca306eee19b55b14b791c728e4c57d6fd4a970
+ sha1sums = aed76333e2abcfe6e977965444de8f23596d533d
+ sha1sums = 71e993a27a10d294a2c0bef68eaba039e1d46916
+
+pkgname = isso
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1045e5bcbefc
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2012-2013 Martin Zimmermann.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14dffd566b98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Reventlov <contact+aur@volcanis.me>
+pkgname=isso
+pkgver=0.9.9
+pkgrel=1
+pkgdesc="A commenting python server similar to disqus"
+arch=('any')
+url="http://posativ.org/isso/"
+license=('MIT')
+depends=('python-werkzeug' 'python-html5lib' 'python-misaka' 'python-itsdangerous' 'python-six' 'sqlite' 'python-setuptools')
+makedepends=('git' 'python')
+backup=('etc/conf.d/isso')
+source=("https://pypi.python.org/packages/source/i/isso/isso-$pkgver.tar.gz"
+"https://pypi.python.org/packages/source/i/isso/isso-$pkgver.tar.gz.asc"
+"isso.service"
+"isso.conf"
+"LICENSE")
+install=$pkgname.install
+validpgpkeys=("7757B21C0C6E5AE4BC6F6462FD1BA15E0E87FE5C")
+noextract=()
+sha1sums=('b6fa8b1c05e1edcd2089c1512ce6f8e0cd2acdaa'
+ 'SKIP'
+ 'f3ca306eee19b55b14b791c728e4c57d6fd4a970'
+ 'aed76333e2abcfe6e977965444de8f23596d533d'
+ '71e993a27a10d294a2c0bef68eaba039e1d46916')
+package() {
+ msg "Starting build..."
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -d -g 1337 -o 1337 "${pkgdir}"/var/lib/isso
+
+ # ... systemd
+ install -D -m 644 "${srcdir}"/isso.service "${pkgdir}"/usr/lib/systemd/system/isso.service
+ # ... common config
+ install -D -m 644 "${srcdir}"/isso.conf "${pkgdir}"/etc/conf.d/isso
+
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/isso.conf b/isso.conf
new file mode 100644
index 000000000000..e0d88f1ee9f4
--- /dev/null
+++ b/isso.conf
@@ -0,0 +1,6 @@
+#
+# Configuration file of isso
+#
+
+#ISSO_CONF="/etc/isso.cfg"
+#See http://posativ.org/isso/docs/configuration/server/
diff --git a/isso.install b/isso.install
new file mode 100644
index 000000000000..56ab0609b616
--- /dev/null
+++ b/isso.install
@@ -0,0 +1,10 @@
+post_install() {
+ getent group isso &>/dev/null || groupadd -r -g 1337 isso >/dev/null
+ getent passwd isso &>/dev/null || useradd -r -u 1337 -g isso -d /var/lib/isso -s /bin/false isso >/dev/null
+}
+
+post_remove() {
+ getent passwd isso &>/dev/null && userdel isso >/dev/null
+ getent group isso &>/dev/null && groupdel isso >/dev/null
+ true
+}
diff --git a/isso.service b/isso.service
new file mode 100644
index 000000000000..316c5c00d606
--- /dev/null
+++ b/isso.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Isso Comment Server
+
+[Service]
+EnvironmentFile=/etc/conf.d/isso
+ExecStart=/usr/bin/isso -c $ISSO_CONF
+
+[Install]
+WantedBy=multi-user.target
+