aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro Henrique2018-12-22 00:41:32 -0300
committerPedro Henrique2018-12-22 00:41:32 -0300
commit1b2d2002b275be684f29376148f2e2efdb8ca0d1 (patch)
treea9002b35c3095cea1e9618a2cf08a2ae33655de2
downloadaur-1b2d2002b275be684f29376148f2e2efdb8ca0d1.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
-rw-r--r--README.md11
-rw-r--r--build.sh2
-rw-r--r--overgrive.install15
6 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b89d21827055
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = overgrive
+ pkgdesc = OverGrive without any extra stuff required in https://www.thefanclub.co.za/overgrive/installation-instructions-arch-linux
+ pkgver = 3.2.3
+ pkgrel = 1
+ url = https://www.thefanclub.co.za/overgrive
+ install = overgrive.install
+ arch = x86_64
+ license = unknown
+ depends = libnotify
+ depends = libappindicator-gtk3
+ depends = python2
+ depends = python2-pyinotify
+ depends = python2-gobject
+ depends = python2-virtualenv
+ provides = overgrive
+ conflicts = overgrive
+ noextract = overgrive-3.2.3-0-any.pkg.tar.xz
+ source = https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.2.3-0-any.pkg.tar.xz
+ md5sums = 6d7cc554e39b6ea399ff88358a58eb78
+
+pkgname = overgrive
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d3731f1422ec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+overgrive*.pkg.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be13c4d9d46f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Pedro Henrique <pedro00dk@gmail.com>
+pkgname=overgrive
+pkgver=3.2.3
+pkgrel=1
+pkgdesc="OverGrive without any extra stuff required in
+https://www.thefanclub.co.za/overgrive/installation-instructions-arch-linux"
+arch=('x86_64')
+url="https://www.thefanclub.co.za/overgrive"
+license=("unknown")
+depends=(
+ libnotify libappindicator-gtk3 python2 python2-pyinotify python2-gobject python2-virtualenv
+)
+provides=("overgrive")
+conflicts=("overgrive")
+install="overgrive.install"
+changelog=
+source=(
+ "https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.2.3-0-any.pkg.tar.xz"
+)
+noextract=("overgrive-3.2.3-0-any.pkg.tar.xz")
+md5sums=("6d7cc554e39b6ea399ff88358a58eb78")
+prepare() {
+ tar --extract --file='./overgrive-3.2.3-0-any.pkg.tar.xz'
+ rm -- './overgrive-3.2.3-0-any.pkg.tar.xz'
+ sed --in-place -- \
+ 's+Exec=python2+Exec=/opt/thefanclub/overgrive/venv/bin/python2+g' \
+ './usr/share/applications/overgrive.desktop'
+}
+package() {
+ cp --recursive -- './opt/' './usr/' "${pkgdir}/"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..17cfb5a58979
--- /dev/null
+++ b/README.md
@@ -0,0 +1,11 @@
+# OverGrive
+
+This package provides an easy way to install OverGrive in arch+based distributions.
+
+The OverGrive site already provides a ```tar.xz``` package, but this package is not in the AUR and requires many steps before and after the package installation through ```pacman```.
+
+This package uses the one obtained from the OverGrive site as base, and executes the necessary steps to make it work without any extra steps.
+
+___
+
+Use ```sh build.sh``` to test the build and generate the ```.SRCINFO```
diff --git a/build.sh b/build.sh
new file mode 100644
index 000000000000..ca50284d7e13
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,2 @@
+makepkg -f
+makepkg --printsrcinfo > .SRCINFO \ No newline at end of file
diff --git a/overgrive.install b/overgrive.install
new file mode 100644
index 000000000000..eb6930ac58f2
--- /dev/null
+++ b/overgrive.install
@@ -0,0 +1,15 @@
+post_install() {
+ virtualenv2 --system-site-packages /opt/thefanclub/overgrive/venv
+ /opt/thefanclub/overgrive/venv/bin/python2 -m pip install --upgrade google-api-python-client
+ /opt/thefanclub/overgrive/venv/bin/python2 -m pip install --upgrade oauth2client
+ sudo glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ sudo rm -rf /opt/thefanclub/overgrive/
+ if [ -z "$(ls -A /opt/thefanclub/)" ]; then
+ sudo rmdir /opt/thefanclub/
+ fi
+} \ No newline at end of file