summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2024-03-08 14:35:07 +0000
committerHanabishi2024-03-08 14:35:07 +0000
commit1b2fec8541e2e6aa8899f2366ec3bc412707e50d (patch)
tree1462dbff352a4517b5f4307912a3f7bb0a23ccd4
parenta4804123b9b43adbadc0ea204e5d1122213249e5 (diff)
downloadaur-1b2fec8541e2e6aa8899f2366ec3bc412707e50d.tar.gz
Update license & minor edits
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 310bd416f14b..f49ee1f08402 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = torrent-file-editor
pkgrel = 2
url = https://torrent-file-editor.github.io/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = cmake
makedepends = qt5-tools
depends = qt5-base
diff --git a/PKGBUILD b/PKGBUILD
index 71214ad0a647..b76913cf55ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgrel=2
pkgdesc='Qt based GUI tool designed to create and edit .torrent files'
arch=('x86_64')
url="https://${pkgname}.github.io/"
-license=('GPL3')
+license=('GPL-3.0-or-later')
if [ "${QT6_BUILD}" ]; then
depends=('qt6-base')
@@ -24,14 +24,13 @@ source=("https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/$
sha256sums=('78b69e0151c5998b4df8b69225e7930c18b7d4419eeaabcad769df0f38a86292')
build() {
- cmake -B "build" -S "${_snapshot}" \
+ cmake -B 'build' -S "${_snapshot}" \
-DCMAKE_INSTALL_PREFIX=/usr \
"-D${_buildflag}"
- cmake --build "build"
+ cmake --build 'build'
}
package() {
- DESTDIR="${pkgdir}" cmake --install "build"
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${_snapshot}/LICENSE"
+ DESTDIR="${pkgdir}" cmake --install 'build'
}