summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-02-03 06:59:00 +0000
committerGeorge Rawlinson2022-02-03 06:59:00 +0000
commit1b30661322c786ee8bc0dcbd3481cbf3191e2fe9 (patch)
tree104cf6f22f983b89906e17befef6567edbdbcaef
parent318823a7feb0ddd33a4b8bd9eda66a2d668fbe33 (diff)
downloadaur-1b30661322c786ee8bc0dcbd3481cbf3191e2fe9.tar.gz
upgpkg: pounce 3.0-1
New upstream release.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
2 files changed, 37 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59afc312dbfb..bb0a9b017a77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = pounce
- pkgdesc = A a multi-client, TLS-only IRC bouncer using a multiple-consumer ring buffer and the IRCv3.2 server-time extension to communicate with clients.
- pkgver = 2.4
+ pkgdesc = A multi-client, TLS-only IRC bouncer
+ pkgver = 3.0
pkgrel = 1
- url = https://git.causal.agency/pounce/
+ url = https://git.causal.agency/pounce
arch = x86_64
license = GPL3
+ makedepends = git
depends = libretls
- source = https://git.causal.agency/pounce/snapshot/pounce-2.4.tar.gz
- md5sums = 3d7f95545b8b3fad435aa93d684e11be
+ depends = libxcrypt
+ source = git+https://git.causal.agency/pounce.git#commit=1d217a2b9e733a825c3ce4b2dc5b5e5d2ada5d4b
+ b2sums = SKIP
pkgname = pounce
diff --git a/PKGBUILD b/PKGBUILD
index 5c2a6cab9d3f..081ca9c22657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,41 @@
-# Original Maintainer: Evan McCarthy <evan@mccarthy.mn>
-# Maintainer: neko <hi@neko.vg>
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+# Contributor: Evan McCarthy <evan@mccarthy.mn>
+# Contributor: neko <hi@neko.vg>
pkgname=pounce
-pkgver=2.4
+pkgver=3.0
pkgrel=1
-pkgdesc='A a multi-client, TLS-only IRC bouncer using a multiple-consumer ring buffer and the IRCv3.2 server-time extension to communicate with clients.'
+pkgdesc='A multi-client, TLS-only IRC bouncer'
arch=('x86_64')
-url="https://git.causal.agency/${pkgname}/"
+url="https://git.causal.agency/pounce"
license=('GPL3')
-depends=('libretls')
-source=("https://git.causal.agency/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
-md5sums=('3d7f95545b8b3fad435aa93d684e11be')
+depends=('libretls' 'libxcrypt')
+makedepends=('git')
+_commit='1d217a2b9e733a825c3ce4b2dc5b5e5d2ada5d4b'
+source=("git+https://git.causal.agency/pounce.git#commit=$_commit")
+b2sums=('SKIP')
+pkgver() {
+ cd pounce
+
+ git describe --tags
+}
+
+prepare() {
+ cd pounce
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+}
build() {
- cd "${pkgname}-${pkgver}"
- ./configure --prefix=/usr
- make all
+ cd pounce
+
+ make all
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
+ cd pounce
+
+ make DESTDIR="$pkgdir" install
}