summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2023-04-04 20:24:47 -0400
committerDarvin Delgado2023-04-04 20:24:47 -0400
commit1b54ba64d9da983b5166843ae2153cb878ccb2f8 (patch)
tree1be0770a78cd659932277ab68c3e8bb570f7fa60
parent08a75dac57e752ab83ef7f052c78dbe6eef9372c (diff)
downloadaur-1b54ba64d9da983b5166843ae2153cb878ccb2f8.tar.gz
small changes
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5352159a44a6..51d6e9f471a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,7 +23,7 @@ pkgbase = mangohud-git
conflicts = mangohud-common
conflicts = mangohud-common-git
replaces = mangohud-common-git
- source = mangohud::git+https://github.com/flightlessmango/MangoHud
+ source = mangohud-git::git+https://github.com/flightlessmango/MangoHud
sha512sums = SKIP
pkgname = mangohud-git
diff --git a/.gitignore b/.gitignore
index 481375e4a41f..1048b52b32c4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
mangohud
+mangohud-git
src
pkg
*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index a36c1ece4ee3..42ab7ae21863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
-_pkgname=mangohud
pkgname=mangohud-git
pkgver=0.6.8.r145.g020e848
pkgrel=1
@@ -17,11 +16,11 @@ optdepends=(
provides=('mangohud' 'mangohud-common')
conflicts=('mangohud' 'mangohud-common' 'mangohud-common-git')
replaces=('mangohud-common-git')
-source=("${_pkgname%"-git"}::git+$url")
+source=("$pkgname::git+$url")
sha512sums=('SKIP')
pkgver() {
- cd "${_pkgname%"-git"}"
+ cd $pkgname
git describe --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
@@ -29,7 +28,7 @@ build() {
local meson_options=(
--wrap-mode=forcefallback
-Dtests=disabled
- "${_pkgname%"-git"}"
+ $pkgname
)
arch-meson "${meson_options[@]}" build
@@ -43,5 +42,5 @@ package() {
mv "$pkgdir/usr/lib/libMangoHud.so" "$pkgdir/usr/lib/mangohud/"
fi
- install -Dm664 "${_pkgname%"-git"}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm664 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}