summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2023-12-15 16:01:26 +0100
committerGilrain2023-12-15 16:01:26 +0100
commit1b5afb2c369aaf165a2a539c720bad04b8237942 (patch)
treed36c738e2d1ae3991bb736a693a26f98dc8da2a9
parentf840beb10446a03672990be86270d6e62f2aaf97 (diff)
downloadaur-1b5afb2c369aaf165a2a539c720bad04b8237942.tar.gz
Update to 5.5.0.10-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--changelog20
-rw-r--r--service.patch27
4 files changed, 36 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8d4b69b69f3..6b172ce1a894 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = asf
- pkgver = 5.4.13.4
+ pkgver = 5.5.0.10
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
install = install
@@ -9,16 +9,16 @@ pkgbase = asf
arch = aarch64
license = Apache
makedepends = git
- makedepends = dotnet-sdk>=7.0
- makedepends = aspnet-runtime>=7.0
- source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=5.4.13.4?signed
+ makedepends = dotnet-sdk>=8.0
+ makedepends = aspnet-runtime>=8.0
+ source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=5.5.0.10?signed
source = service.patch
source = asf.env
source = ASF.json
source = NLog.config
validpgpkeys = 1268A81616AFDC20C55779ED6B138B4C64555AEA
sha256sums = SKIP
- sha256sums = cc6828798785b6b5e53b0b231ba7167c727295dfc95a307cdeb16b7c703d197e
+ sha256sums = aef764cd0cdad9356221a7c8cc0d99d153935ceb1a874dd5729acbb7cf47fd37
sha256sums = ec82f54a9b362e2305a775eb1473522636ab724f18d846828410c39344801db4
sha256sums = c300c5ce63c0237d7558b5b303159b8e2a8e5323f581cc8435dd2a6f1ead5332
sha256sums = 636f3a125071cabfcb0c3828c6f9b0ec613789ab846ff71448d1a6eb110aee3f
@@ -45,7 +45,7 @@ pkgname = asf-plugin-signinwithsteam
pkgname = asf
pkgdesc = Steam cards farmer.
- depends = aspnet-runtime>=7.0
+ depends = aspnet-runtime>=8.0
optdepends = asf-ui: standalone web interface for ASF
optdepends = asf-plugin-itemsmatcher
optdepends = asf-plugin-mobileauthenticator
diff --git a/PKGBUILD b/PKGBUILD
index fda5c5e7f731..63ea21abc6a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@ pkgname=('asf-plugin-steamtokendumper'
'asf-plugin-periodicgc'
'asf-plugin-signinwithsteam'
'asf')
-pkgver="5.4.13.4"
+pkgver="5.5.0.10"
pkgrel=1
arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/JustArchiNET/ArchiSteamFarm"
license=('Apache')
-makedepends=('git' 'dotnet-sdk>=7.0' 'aspnet-runtime>=7.0')
-dotnet_framework='net7.0'
+makedepends=('git' 'dotnet-sdk>=8.0' 'aspnet-runtime>=8.0')
+dotnet_framework='net8.0'
changelog=changelog
install=install
source=("asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=${pkgver}?signed"
@@ -24,7 +24,7 @@ source=("asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=${pkgve
"NLog.config")
validpgpkeys=('1268A81616AFDC20C55779ED6B138B4C64555AEA')
sha256sums=('SKIP'
- 'cc6828798785b6b5e53b0b231ba7167c727295dfc95a307cdeb16b7c703d197e'
+ 'aef764cd0cdad9356221a7c8cc0d99d153935ceb1a874dd5729acbb7cf47fd37'
'ec82f54a9b362e2305a775eb1473522636ab724f18d846828410c39344801db4'
'c300c5ce63c0237d7558b5b303159b8e2a8e5323f581cc8435dd2a6f1ead5332'
'636f3a125071cabfcb0c3828c6f9b0ec613789ab846ff71448d1a6eb110aee3f')
@@ -102,7 +102,7 @@ package_asf-plugin-signinwithsteam() {
package_asf() {
pkgdesc="Steam cards farmer."
- depends=('aspnet-runtime>=7.0')
+ depends=('aspnet-runtime>=8.0')
optdepends=('asf-ui: standalone web interface for ASF'
'asf-plugin-itemsmatcher'
'asf-plugin-mobileauthenticator'
diff --git a/changelog b/changelog
index 5a64da05589b..8de3b1bcd6c0 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,23 @@
+2023-12-15 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 5.5.0.10-1:
+ ❗ ASF is now based on .NET 8 platform. While mostly transparent and compatible for end-users, new .NET major version brings a lot of improvements, enhancements, bugfixes and optimizations. It also opens new ASF version cycle, V5.5, due to potential breaking changes (@JustArchi).
+ ❗ ASF no longer uses API keys, previous functionality was rewritten to access tokens instead. This also means that ASF will no longer generate API key on each run, you can revoke existing API keys after update if you'd like to (@JustArchi, #3084).
+ 💥 .NET 8 dropped support for some obsolete OSes, check out compatibility wiki section for up-to-date requirements. All currently supported OSes should work without any issues. Naturally, people running generic ASF variant will need to update their SDK/runtime to version 8.0 (@JustArchi).
+ 💥 Dropped support for generic-netf platform. Check relevant issue for more details if you're affected (@JustArchi, #3060).
+ 💥 Our systemd units got upgraded with latest security enhancements, this requires acceptably recent v247 version or newer, which is the case with all currently supported OSes (@JustArchi).
+ ✨ Side effect of API keys removal brings limited support for trading on limited accounts, in particular they can do everything that Steam allows, for example accepting donations. Previously they had completely restricted trading functionality (@JustArchi).
+ ✨ Enhanced std command in our STD plugin to std [Bots], the command now allows to submit data to SteamDB in one-time mode even with disabled STD config (@JustArchi).
+ ✨ Improved PublicListing announcements logic to decrease amount of traffic and workload, which should be especially visible on bots with huge inventories. This is still a bit experimental at this stage on our side, but seems to work much better (@JustArchi, #3073).
+ ✨ Enhanced 2fainit to produce maFile.NEW file that is fully compatible with SDA for import (@JustArchi).
+ ✨ Added Steam Winter Sale 2023 to SalesBlacklist (@nolddor, #3098).
+ 🔧 ASF will now use CurrentCulture as announced Steam client language, which influences e.g. language in e-mails being sent (@JustArchi, #3093).
+ 🔧 Fixed relative path in ASF_CRYPTKEY_FILE not working when using custom ASF_PATH (@JustArchi).
+ 🔧 Fixed regression introduced while fixing #3051 that sometimes made console input non-operative (@JustArchi, #3075).
+ 🔧 Fixed Bosnian language not being recognized out of the box for ASF (@JustArchi).
+ 🔧 Fixed potential ASF crash when user spent too much time entering the password (@JustArchi).
+ 🖥️ Latest ASF-ui with new features, improvements and bugfixes (@MrBurrBurr).
+ 🌐 Updated localization provided by our community (@JustArchi-ArchiBot).
+ 🔁 Usual amount of other core improvements, optimizations and bugfixes (@JustArchi).
2023-11-13 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 5.4.13.4-1:
[!] ASF uses new code for redeeming keys now. While this is mostly transparent for end-users, there is a breaking change in the ASF API RedeemKey() functionality, you may need to recompile your plugins if you're making use of that function. Notable difference is that Steam sends e-mails upon key activations now (@JustArchi #3058).
diff --git a/service.patch b/service.patch
index 8c7056be6c9f..768d78dd434b 100644
--- a/service.patch
+++ b/service.patch
@@ -1,34 +1,17 @@
---- ArchiSteamFarm@.service.org 2022-11-16 16:46:05.036505989 +0100
-+++ ArchiSteamFarm@.service 2022-11-16 16:44:22.570447671 +0100
-@@ -3,7 +3,7 @@
-
+--- ArchiSteamFarm@.service.org 2023-11-19 13:52:16.626353458 +0100
++++ ArchiSteamFarm@.service 2023-11-19 13:53:50.443707084 +0100
+@@ -4,5 +4,5 @@
[Service]
EnvironmentFile=-/etc/asf/%i
-ExecStart=/home/%i/ArchiSteamFarm/ArchiSteamFarm --no-restart --process-required --service --system-required
+ExecStart=/usr/bin/dotnet /usr/lib/asf/ArchiSteamFarm.dll --no-restart --process-required --service --system-required
Restart=on-success
RestartSec=1s
- SyslogIdentifier=asf-%i
-@@ -27,7 +27,8 @@
- ProtectKernelTunables=yes
+@@ -29,5 +29,6 @@
ProtectProc=invisible
ProtectSystem=strict
-ReadWritePaths=/home/%i/ArchiSteamFarm /tmp
+ReadWritePaths=%h /tmp
+StateDirectory=%i
RemoveIPC=yes
- RestrictAddressFamilies=AF_INET AF_INET6
- RestrictNamespaces=yes
-@@ -39,9 +40,9 @@
- # TODO: Requires systemd v247+ due to https://github.com/systemd/systemd/issues/16666 and https://github.com/JustArchiNET/ArchiSteamFarm/issues/2739
- # Since we don't want to enforce OS upgrade for everybody just yet, it's commented out for now
- # We'll likely enforce it when .NET switches to Debian 11+ requirement
--#SecureBits=noroot-locked
--#SystemCallFilter=@system-service
--#SystemCallFilter=~@privileged
-+SecureBits=noroot-locked
-+SystemCallFilter=@system-service
-+SystemCallFilter=~@privileged
-
- [Unit]
- After=network.target
+ RestrictAddressFamilies=AF_INET AF_INET6 AF_NETLINK AF_UNIX