summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-02 19:15:30 +0200
committerMarcell Meszaros2022-06-02 21:05:53 +0200
commit1b6cd1e8c90c4c0fe9493122dd1254dcacbfdc72 (patch)
tree04f1bf1d3d4a686143ef3905a14196fe1f812e95
parent31abfe31d95e01e143e110f72f9c81812e3bef58 (diff)
downloadaur-1b6cd1e8c90c4c0fe9493122dd1254dcacbfdc72.tar.gz
updpkg 1.20.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d60060b816ed..86e9fadd4e60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,28 @@
pkgbase = lib32-gst-plugins-ugly
pkgdesc = Multimedia graph framework - ugly plugins (32-bit)
- pkgver = 1.18.5
- pkgrel = 2
+ pkgver = 1.20.2
+ pkgrel = 1
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL2.1
- makedepends = git
makedepends = meson
makedepends = python
- depends = lib32-gst-plugins-base-libs>=1.18.5
+ depends = lib32-gst-plugins-base-libs>=1.20.2
depends = lib32-a52dec
depends = lib32-libcdio
depends = lib32-libdvdread
depends = lib32-libmpeg2
depends = lib32-opencore-amr
depends = lib32-x264
- source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly.git#commit=bd1dfb44475ab04d42b217acdf90942e0b7893b5
- sha256sums = SKIP
+ source = https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-1.20.2.tar.xz
+ sha256sums = b43fb4df94459afbf67ec22003ca58ffadcd19e763f276dca25b64c848adb7bf
pkgname = lib32-gst-plugins-ugly
- depends = lib32-gst-plugins-base-libs>=1.18.5
+ depends = lib32-gst-plugins-base-libs>=1.20.2
depends = lib32-a52dec
depends = lib32-libcdio
depends = lib32-libdvdread
depends = lib32-libmpeg2
- depends = lib32-libsidplay
depends = lib32-opencore-amr
depends = lib32-x264
- depends = gst-plugins-ugly>=1.18.5
+ depends = gst-plugins-ugly>=1.20.2
diff --git a/PKGBUILD b/PKGBUILD
index 0171828e91d8..24c0a2d71429 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_basename='gst-plugins-ugly'
pkgname="lib32-${_basename}"
-pkgver=1.18.5
-pkgrel=2
+pkgver=1.20.2
+pkgrel=1
pkgdesc='Multimedia graph framework - ugly plugins (32-bit)'
url='https://gstreamer.freedesktop.org/'
arch=('x86_64')
@@ -21,38 +21,33 @@ depends=(
'lib32-x264'
)
makedepends=(
- 'git'
'meson'
'python'
)
-_commit='bd1dfb44475ab04d42b217acdf90942e0b7893b5' # tags/1.18.5^0
-source=("git+https://gitlab.freedesktop.org/gstreamer/${_basename}.git#commit=$_commit")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${_basename}"
-
- git describe --tags | sed 's/-/+/g'
-}
+source=("${url}src/"${_basename}"/"${_basename}"-${pkgver}.tar.xz")
+sha256sums=('b43fb4df94459afbf67ec22003ca58ffadcd19e763f276dca25b64c848adb7bf')
prepare() {
- cd "${_basename}"
-}
+ # disable Python module import during build, which is not actually used for release versions
+ sed -e 's/python3/#python3/' -i "${_basename}-${pkgver}/meson.build"
-build() {
export CC='gcc -m32'
export CXX='g++ -m32'
+ export CFLAGS+=" ${LDFLAGS}" # otherwise meson (or the project) ignores LDFLAGS
export PKG_CONFIG='/usr/bin/i686-pc-linux-gnu-pkg-config'
- arch-meson "${_basename}" 'build' \
+ arch-meson "${_basename}-${pkgver}" 'build' \
--libdir='lib32' \
--libexecdir='lib32' \
-Ddoc='disabled' \
+ -Dgpl='enabled' \
-Dsidplay='disabled' \
-Dgobject-cast-checks='disabled' \
- -Dpackage-name='GStreamer Ugly Plugins (Arch Linux)' \
+ -Dpackage-name="Arch Linux ${pkgname} ${pkgver}-${pkgrel}" \
-Dpackage-origin='https://www.archlinux.org/'
+}
+build() {
meson compile -C 'build'
}