summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122020-08-23 10:32:50 +0200
committerwillemw122020-08-23 10:32:50 +0200
commit1b84a4f3f03f675ba5113b63bf3c53a7629f6683 (patch)
tree7510951b0ced69b4e248a8ee0112bf1084743301
downloadaur-1b84a4f3f03f675ba5113b63bf3c53a7629f6683.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee1991eb5c92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pywapi-git
+ pkgdesc = Python wrapper around the Yahoo! Weather, Weather.com and NOAA APIs
+ pkgver = r126.7f05282
+ pkgrel = 1
+ url = https://launchpad.net/python-weather-api
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ provides = python-pywapi
+ conflicts = python-pywapi
+ source = python-pywapi-git::git+https://git.launchpad.net/~khurshid-alam/python-weather-api/+git/trunk
+ md5sums = SKIP
+
+pkgname = python-pywapi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3b2d7fe442a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+pkgname=python-pywapi-git
+pkgver=r126.7f05282
+pkgrel=1
+pkgdesc="Python wrapper around the Yahoo! Weather, Weather.com and NOAA APIs"
+arch=('any')
+url="https://launchpad.net/python-weather-api"
+license=('MIT')
+depends=('python')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+#source=($pkgname::git+https://github.com/khurshid-alam/python-weather-api.git)
+source=($pkgname::git+https://git.launchpad.net/~khurshid-alam/python-weather-api/+git/trunk)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+package() {
+ cd $pkgname
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+