summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Pesik2015-07-08 14:13:57 +0100
committerEmile Pesik2015-07-08 14:13:57 +0100
commit1b86fa95df3f7f642ce1713d2a111ed1f2446bca (patch)
treec6e5131f8a6ef80170d143819b85e7ae56a38dd2
downloadaur-1b86fa95df3f7f642ce1713d2a111ed1f2446bca.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..913fe39d1d47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = rephrase
+ pkgdesc = A specialized passphrase recovery tool for GnuPG.
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://www.roguedaemon.net/rephrase/
+ arch = any
+ license = GPL
+ depends = gnupg
+ source = http://www.roguedaemon.net/rephrase/rephrase-0.1.tar.gz
+ md5sums = be53cd4988efa1a226f3dc15decf12a9
+
+pkgname = rephrase
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f103cec6f729
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Emile Pesik <emile [at] aerion [dot] co [dot] uk>
+pkgname=rephrase
+pkgver=0.1
+pkgrel=1
+pkgdesc="A specialized passphrase recovery tool for GnuPG."
+arch=(any)
+url="http://www.roguedaemon.net/rephrase/"
+license=("GPL")
+depends=('gnupg')
+source=("http://www.roguedaemon.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('be53cd4988efa1a226f3dc15decf12a9')
+
+build() {
+ cd $srcdir/${pkgname}-${pkgver}
+ make GPG=/usr/bin/gpg
+ }
+
+package() {
+ cd $srcdir/${pkgname}-${pkgver}
+ make BINDIR="${pkgdir}/usr/bin" DESTDIR="${pkgdir}" install
+ }