summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-03-14 00:44:48 +0100
committerFabioLolix2022-03-14 00:44:48 +0100
commit1b9ce56b3ae11175dba3f8f382dd4bc74ec1414c (patch)
treea20993b5ce43e03cc5c31ae2a393f055025ed184
parentc094adb840547a1b44e257b9cfe02fe21d86b0ae (diff)
downloadaur-1b9ce56b3ae11175dba3f8f382dd4bc74ec1414c.tar.gz
revision
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD70
2 files changed, 67 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecf9c63d2071..b9813f1c4359 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
-# Generated by mksrcinfo v8
-# Sun Dec 4 15:01:21 UTC 2016
pkgbase = wxgtk-git
- pkgdesc = Cross-Platform GUI Library - GTK+ port
- pkgver = r62004.4775853
+ pkgdesc = GTK+3 implementation of wxWidgets API for GUI
+ pkgver = 3.1.5.r1546.g1c5e66a12c
pkgrel = 1
url = https://www.wxwidgets.org
- arch = i686
arch = x86_64
license = custom: wxWindows Library Licence
makedepends = git
- makedepends = cppunit
makedepends = glu
depends = gtk3
- depends = webkitgtk
- depends = libmspack
depends = gst-plugins-bad
depends = libnotify
- provides = wxgtk
- conflicts = wxgtk
- source = wxgtk::git+https://github.com/wxWidgets/wxWidgets.git
+ depends = libsecret
+ provides = wxgtk3
+ provides = wxgtk-common
+ conflicts = wxgtk3
+ conflicts = wxgtk-common
+ conflicts = wxgtk2
+ source = wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git
+ source = git+https://github.com/wxWidgets/Catch.git
+ source = git+https://github.com/wxWidgets/pcre.git
+ source = git+https://github.com/wxWidgets/nanosvg
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = wxgtk-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0355e5ada846..8e7c23b33c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,69 @@
-# Maintainer: Peter Mattern <pmattern at arcor dot de>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Peter Mattern <pmattern at arcor dot de>
-_pkgname=wxgtk
-pkgname=$_pkgname-git
-pkgver=r62004.4775853
+pkgname=wxgtk-git
+pkgver=3.1.5.r1546.g1c5e66a12c
pkgrel=1
-pkgdesc='Cross-Platform GUI Library - GTK+ port'
-arch=('i686' 'x86_64')
+pkgdesc="GTK+3 implementation of wxWidgets API for GUI"
+arch=(x86_64)
url='https://www.wxwidgets.org'
license=('custom: wxWindows Library Licence')
-depends=('gtk3' 'webkitgtk' 'libmspack' 'gst-plugins-bad' 'libnotify')
-makedepends=('git' 'cppunit' 'glu')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("${_pkgname}::git+https://github.com/wxWidgets/wxWidgets.git")
-sha256sums=("SKIP")
+depends=(gtk3 gst-plugins-bad libnotify libsecret)
+makedepends=(git glu)
+provides=(wxgtk3 wxgtk-common)
+conflicts=(wxgtk3 wxgtk-common wxgtk2)
+source=("wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git"
+ "git+https://github.com/wxWidgets/Catch.git"
+ "git+https://github.com/wxWidgets/pcre.git"
+ "git+https://github.com/wxWidgets/nanosvg")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd wxwidgets
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd $_pkgname
+prepare() {
+ cd wxwidgets
+ git config submodule.3rdparty/catch.url "${srcdir}/Catch"
+ git submodule update --init 3rdparty/catch
+
+ git config submodule.3rdparty/pcre.url "${srcdir}/pcre"
+ git submodule update --init 3rdparty/pcre
+
+ git config submodule.3rdparty/nanosvg.url "${srcdir}/nanosvg"
+ git submodule update --init 3rdparty/nanosvg
+
./autogen.sh
- ./configure --prefix=/usr --with-gtk=3 --enable-stl --with-libmspack
+}
+
+build() {
+ cd wxwidgets
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --with-gtk=3 \
+ --with-opengl \
+ --enable-unicode \
+ --enable-graphics_ctx \
+ --enable-mediactrl \
+ --enable-webview \
+ --with-regex=builtin \
+ --with-libpng=sys \
+ --with-libxpm=sys \
+ --with-libjpeg=sys \
+ --with-libtiff=sys \
+ --disable-precomp-headers
make
make -C locale allmo
}
package() {
- cd $_pkgname
+ cd wxwidgets
make DESTDIR="$pkgdir" install
+
install -D -m644 docs/licence.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}