summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2021-06-28 16:20:46 +1000
committerMatthew Gamble2021-06-28 16:20:46 +1000
commit1bab4c7de70974e8f8aced02747b7f9284625278 (patch)
treecb87d16a37ddb89d67386a372e8e9827fa40687e
parent0a47739a62fe6ac3e145966a0a04e2500791245d (diff)
downloadaur-1bab4c7de70974e8f8aced02747b7f9284625278.tar.gz
Update to latest release
Also clean up various things, and include documentation with package.
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD29
3 files changed, 28 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf3a86a6c2a6..6507946f2cb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-coloredlogs
pkgdesc = Colored terminal output for Python's logging module
- pkgver = 15.0
+ pkgver = 15.0.1
pkgrel = 1
url = https://github.com/xolox/python-coloredlogs
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-sphinx
depends = python
depends = python-humanfriendly
- source = https://github.com/xolox/python-coloredlogs/archive/15.0.tar.gz
- md5sums = 1999ab887e0bf410921c85ade47c1317
+ source = https://github.com/xolox/python-coloredlogs/archive/15.0.1.tar.gz
+ sha256sums = e8161222671bb129f7936cd220c275a3cbc0a6c22313bd4483114b9526e5695f
pkgname = python-coloredlogs
-
diff --git a/.gitignore b/.gitignore
index e28f6f20ed95..c8967cd2f23a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,6 @@
-src
-pkg
+/src/
+/pkg/
*.sign
-*.xz
-*.pkg*
+*.pkg.tar.*
*.part
*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 42bd42f969d5..869ecd60d3b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,34 @@
# Maintainer: Maikel Wever <maikelwever@gmail.com>
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
pkgname=python-coloredlogs
-pkgver=15.0
+pkgver=15.0.1
pkgrel=1
pkgdesc="Colored terminal output for Python's logging module"
+arch=('any')
url="https://github.com/xolox/python-coloredlogs"
license=('MIT')
depends=('python' 'python-humanfriendly')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-sphinx')
source=("https://github.com/xolox/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('1999ab887e0bf410921c85ade47c1317')
-arch=('any')
+sha256sums=('e8161222671bb129f7936cd220c275a3cbc0a6c22313bd4483114b9526e5695f')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ python setup.py build
+
+ cd docs
+ sphinx-build -nb html . build/html
+}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- cp LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+ cd "${pkgname}-${pkgver}"
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-coloredlogs/LICENSE.txt"
+ install -Dm644 CHANGELOG.rst "${pkgdir}/usr/share/doc/python-coloredlogs/CHANGELOG.rst"
+ cp -r docs/build/html "${pkgdir}/usr/share/doc/python-coloredlogs/html"
}
# vim:set ts=2 sw=2 et: