summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-26 22:03:41 -0800
committerxiota2023-12-26 22:32:31 -0800
commit1be1e4575970aa3e3778cd0744bb26b8b518da57 (patch)
tree17b14d9b893254efa56442bdaec254308ecb56e5
parent1f7a4699faf9a0ba94dbf34bf2fc8dfca0000ea7 (diff)
downloadaur-1be1e4575970aa3e3778cd0744bb26b8b518da57.tar.gz
5.0.r20842
* link with lld * minor updates * prune contributor list People who were never directly involved with this package may not appreciate having their email addresses distributed.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD31
2 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21a74db51f38..356db64cb07d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = dolphin-emu-debugfast-git
- pkgdesc = A Gamecube / Wii / Triforce emulator
- pkgver = 5.0.r20840.g57327be7f3
+ pkgdesc = A Gamecube and Wii emulator
+ pkgver = 5.0.r20842.g3cb5d3455f
pkgrel = 1
url = https://github.com/dolphin-emu/dolphin
arch = x86_64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = cmake
makedepends = git
makedepends = python
makedepends = clang
- makedepends = lld
makedepends = llvm
- makedepends = mold
+ makedepends = lld
depends = alsa-lib
depends = bluez-libs
depends = curl
@@ -45,7 +44,6 @@ pkgbase = dolphin-emu-debugfast-git
depends = sdl2
depends = sfml
depends = zstd
- optdepends = pulseaudio: PulseAudio backend
provides = dolphin-emu
provides = dolphin-emu-nogui
provides = dolphin-emu-tool
diff --git a/PKGBUILD b/PKGBUILD
index 0232cbff7e04..9f1c5548262d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,5 @@
# Maintainer: xiota / aur.chaotic.cx
# Contributor: Kerrick Staley <kerrick@kerrickstaley.com>
-# Contributor: schuay <jakob.gruber@gmail.com>
-# Contributor: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Jeremy Newton (Mystro256) <alexjnewt@gmail.com>
## useful links
# https://dolphin-emu.org
@@ -12,7 +9,7 @@
: ${_debugfast:=false}
: ${_build_clang:=true}
-: ${_build_mold:=true}
+: ${_build_mold:=false}
: ${_build_debugfast:=true}
: ${_build_avx:=false}
@@ -25,12 +22,12 @@
# basic info
_pkgname="dolphin-emu"
pkgname="$_pkgname${_pkgtype:-}"
-pkgver=5.0.r20840.g57327be7f3
+pkgver=5.0.r20842.g3cb5d3455f
pkgrel=1
-pkgdesc='A Gamecube / Wii / Triforce emulator'
+pkgdesc='A Gamecube and Wii emulator'
+url="https://github.com/dolphin-emu/dolphin"
+license=('GPL-2.0-or-later')
arch=(x86_64)
-_url="https://github.com/dolphin-emu/dolphin"
-license=(GPL2)
# main package
_main_package() {
@@ -82,16 +79,12 @@ _main_package() {
git
python
)
- optdepends=(
- 'pulseaudio: PulseAudio backend'
- )
options=(!emptydirs)
if [[ "${_build_clang::1}" == "t" ]] ; then
makedepends+=(
clang
- lld
llvm
)
else
@@ -100,6 +93,8 @@ _main_package() {
if [[ "${_build_mold::1}" == "t" ]] ; then
makedepends+=(mold)
+ else
+ makedepends+=(lld)
fi
if [[ "${_build_git::1}" != "t" ]] ; then
@@ -193,8 +188,6 @@ _main_stable() {
# git package
_main_git() {
- url="${_url:?}"
-
provides=(
'dolphin-emu'
'dolphin-emu-nogui'
@@ -243,11 +236,6 @@ prepare() {
}
build() {
- if [[ "${_build_avx::1}" == "t" ]] ; then
- export CFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
- export CXXFLAGS="$(echo "$CXXFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
- fi
-
local _cmake_options=(
-B build
-S "$_pkgname"
@@ -300,6 +288,11 @@ build() {
)
fi
+ if [[ "${_build_avx::1}" == "t" ]] ; then
+ export CFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
+ export CXXFLAGS="$(echo "$CXXFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
+ fi
+
cmake "${_cmake_options[@]}"
cmake --build build
}