summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxgdgsc2015-06-12 20:19:24 +0800
committerxgdgsc2015-06-12 20:19:24 +0800
commit1bed3a0c4e0f5dcc1a1dbcbc3dd4214e17a31c5c (patch)
tree2b58e60e5f406024fd6e74a556706eb2de97af77
downloadaur-1bed3a0c4e0f5dcc1a1dbcbc3dd4214e17a31c5c.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
-rw-r--r--docear.desktop10
4 files changed, 95 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..8ba307fe2faa
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = docear
+ pkgdesc = Docear is an academic literature suite for searching, organizing and creating academic literature, built upon the mind mapping software Freeplane and the reference manager JabRef.
+ pkgver = 1.1.0_stable
+ pkgrel = 1
+ url = http://www.docear.org/
+ install =
+ changelog =
+ arch = any
+ license = GPL 2
+ depends = java-runtime
+ provides = docear
+ source = docear_1.1.0_stable.tar.gz::http://sourceforge.net/projects/docear/files/1.x/1.1.0_stable/docear_linux.tar.gz/download
+ source = docear.desktop
+
+pkgname = docear
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac8925cad3dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = docear
+ pkgdesc = Docear is an academic literature suite for searching, organizing and creating academic literature, built upon the mind mapping software Freeplane and the reference manager JabRef.
+ pkgver = 1.1.0_stable
+ pkgrel = 1
+ url = http://www.docear.org/
+ arch = any
+ license = GPL 2
+ depends = java-runtime
+ provides = docear
+ source = docear_1.1.0_stable.tar.gz::http://sourceforge.net/projects/docear/files/1.x/1.1.0_stable/docear_linux.tar.gz/download
+ source = docear.desktop
+ md5sums = d2429a48c4df9fbbfc5dfac6e10983eb
+ md5sums = 6023a37923cd962f53db05ed5e2a6b21
+
+pkgname = docear
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9715704e84f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Cloud Han <heliumhgy@gmail.com>
+
+pkgname=docear
+pkgver=1.1.0_stable
+pkgrel=1
+pkgdesc="Docear is an academic literature suite for searching, organizing and creating academic literature, built upon the mind mapping software Freeplane and the reference manager JabRef."
+arch=('any')
+url="http://www.docear.org/"
+license=('GPL 2')
+groups=()
+depends=('java-runtime')
+makedepends=()
+optdepends=()
+provides=('docear')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}_${pkgver}.tar.gz::http://sourceforge.net/projects/docear/files/1.x/${pkgver}/${pkgname}_linux.tar.gz/download"
+ "docear.desktop")
+md5sums=('d2429a48c4df9fbbfc5dfac6e10983eb'
+ '6023a37923cd962f53db05ed5e2a6b21')
+noextract=()
+
+build() {
+ # echo "Cleaning src directory..."
+ # find "${srcdir}" -maxdepth 1 -mindepth 1 -type d -exec rm -r {} \;
+ # echo "Cleaned src directory"
+
+ # bsdtar -xf "${pkgname}_${pkgver}.tar.gz"
+ mv "docear-"* "docear-${pkgver}"
+}
+
+package() {
+ install -dm 755 "${pkgdir}/usr/share/docear"
+ cp -r "${srcdir}/docear-${pkgver}"/* "${pkgdir}/usr/share/docear"
+ find "${pkgdir}/usr/share/docear" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/usr/share/docear" -type f -exec chmod 644 {} \;
+ chmod 755 "${pkgdir}/usr/share/docear/docear.sh"
+
+ install -dm 755 "${pkgdir}/usr/bin"
+ echo "#! /bin/sh" > "${pkgdir}/usr/bin/docear"
+ echo "/usr/share/docear/docear.sh \$*" >> "${pkgdir}/usr/bin/docear"
+ chmod 755 "${pkgdir}/usr/bin/docear"
+
+ install -d "${pkgdir}/usr/share/applications"
+ install -Dm 644 "$startdir/docear.desktop" "${pkgdir}/usr/share/applications/docear.desktop"
+
+ # enable antialiasing when start up docear
+ echo "-Dawt.useSystemAAFontSettings=on" >> "${pkgdir}/usr/share/docear/init.xargs"
+}
diff --git a/docear.desktop b/docear.desktop
new file mode 100644
index 000000000000..ef2ed6591b41
--- /dev/null
+++ b/docear.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Docear
+Comment=Free mind-mapping software written in Java, based on Freeplane
+GenericName=
+Exec=/usr/share/docear/docear.sh
+Icon=/usr/share/docear/docear.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Network;