summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 19:04:04 +0300
committerChristoph Fink2023-03-26 19:04:04 +0300
commit1c0f583a9ca0834d7f1b69c6aaac22dff8dae8f5 (patch)
treefd0443ce45e609d368a17b5643517816ad29bab2
parentb9220ce80483cc13cdfcb1a9a8952b19bcca46f3 (diff)
downloadaur-1c0f583a9ca0834d7f1b69c6aaac22dff8dae8f5.tar.gz
upgpkg: r-withr 2.5.0-3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
2 files changed, 26 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a632079f5b7..55d0ef75a43b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,10 @@
pkgbase = r-withr
pkgdesc = Lightweight Well-Known Geometry Parsing
pkgver = 2.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://cran.r-project.org/package=withr
arch = any
license = MIT
- checkdepends = r-callr
- checkdepends = r-covr
- checkdepends = r-dbi
- checkdepends = r-knitr
- checkdepends = r-rmarkdown
- checkdepends = r-rsqlite
- checkdepends = r-testthat
- checkdepends = texlive-core
depends = r>=3.2.0
optdepends = r-callr
optdepends = r-covr
diff --git a/PKGBUILD b/PKGBUILD
index 4dfb353978de..9b2503addd1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgdesc="Lightweight Well-Known Geometry Parsing"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
arch=("any")
depends=(
@@ -24,11 +24,26 @@ optdepends=(
"r-rmarkdown"
"r-rsqlite"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat"
- "texlive-core"
-)
+
+# The unittests for `r-withr` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-withr`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# "texlive-core"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("b472aef752317feedab16ab01557f28cdd30d8f2c6902b1a496f308165c1e02f7a8859cc791acf714748ad0a1b2d58dc9567cacfa0083a8427eb487820d8ab10")
@@ -38,14 +53,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- R_BUILD_TAR="tar" R_LIBS="build/" R CMD check "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi