summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-09-19 11:22:56 +0800
committerUniversebenzene2020-09-19 11:22:56 +0800
commit1c0f77deeace81caa27d0b1745895e21255c4bbb (patch)
treead70e4ede7cbb4ef29dab12f478f125cbd49e638
parent32cc894ef20f0a545fc0b660b887dd5154375f6c (diff)
downloadaur-1c0f77deeace81caa27d0b1745895e21255c4bbb.tar.gz
Update to version 1.2.19
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
-rw-r--r--fix_typo.patch11
4 files changed, 36 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26e6b962404a..c5536032493c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
- pkgver = 1.2.18
+ pkgver = 1.2.19
pkgrel = 1
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
arch = x86_64
license = BSD
- makedepends = python-setuptools
+ checkdepends = python-pytest
+ checkdepends = python-astropy
+ makedepends = python-setuptools-scm
makedepends = python-numpy
makedepends = qd>=2.3.7
makedepends = python-sphinx-automodapi
makedepends = python-numpydoc
- source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.18.tar.gz
+ source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.19.tar.gz
+ source = fix_typo.patch
source = fix_doc_warning.patch
- md5sums = a90b12aaf7eeb99807ad2ebf505ad84c
+ md5sums = 73b1ed911597c4086bdece9f0ca288bd
+ md5sums = 376f76ebdf3c52048a113c386c091210
md5sums = fed5395d45a2275ccd5e0d63956ecddf
pkgname = python-spherical_geometry
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,5 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index d7fdf74ef5e5..10c37263853b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,27 @@
pkgbase=python-spherical_geometry
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.2.18
+pkgver=1.2.19
pkgrel=1
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/resources/software_hardware/stsci_python"
license=('BSD')
-makedepends=('python-setuptools' 'python-numpy' 'qd>=2.3.7' 'python-sphinx-automodapi' 'python-numpydoc')
-#checkdepends=('python-pytest' 'python-astropy')
+makedepends=('python-setuptools-scm' 'python-numpy' 'qd>=2.3.7' 'python-sphinx-automodapi' 'python-numpydoc')
+checkdepends=('python-pytest' 'python-astropy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ 'fix_typo.patch'
'fix_doc_warning.patch')
-md5sums=('a90b12aaf7eeb99807ad2ebf505ad84c'
+md5sums=('73b1ed911597c4086bdece9f0ca288bd'
+ '376f76ebdf3c52048a113c386c091210'
'fed5395d45a2275ccd5e0d63956ecddf')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
- patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
+# patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
+ patch -Np1 -i "${srcdir}/fix_typo.patch"
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export USE_SYSTEM_QD=1
}
@@ -30,11 +34,13 @@ build() {
python setup.py build_sphinx
}
-#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-#
-# pytest
-#}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ cp "build/lib.linux-${CARCH}-${_pyver}/${_pyname}/math_util.cpython-${_pyver/./}-${CARCH}-linux-gnu.so" \
+"${_pyname}"
+ pytest || warning "Tests failed"
+}
package_python-spherical_geometry() {
depends=('python>=3.5' 'python-numpy>=1.10.0' 'qd>=2.3.7' 'python-astropy>=0.4')
diff --git a/fix_typo.patch b/fix_typo.patch
new file mode 100644
index 000000000000..025239a3fe46
--- /dev/null
+++ b/fix_typo.patch
@@ -0,0 +1,11 @@
+--- a/README.rst 2020-09-19 05:16:43.000000000 +0800
++++ b/README.rst 2020-09-19 10:36:34.102121731 +0800
+@@ -108,7 +108,7 @@
+ should have a clockwise order. When creating a new spherical polygon,
+ the order of the points defining a polygon will be reversed if they are
+ not in clockwise order. The method ``SphericalPolygon.is_clockwise`` is
+-used to est if the points are in clockwise order. It takes two
++used to test if the points are in clockwise order. It takes two
+ successive sides and computes the normal vector to the sides. If the
+ normal vector points inward towards the center of the sphere, the two
+ sides are counter clockwise. If the normal vector points outward, the