summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-06-11 13:31:28 -0600
committerMark Wagie2023-06-11 13:31:28 -0600
commit1c14385619b4658595ecb830276d77fa871ec92b (patch)
tree6db786a146016ab0df6a333489f05ef196d744f2
parent80699455220c789ec126066088b04eeb5af75e94 (diff)
downloadaur-1c14385619b4658595ecb830276d77fa871ec92b.tar.gz
4.10
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD12
-rw-r--r--clight.install2
3 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 888e249baa69..936bf705f1ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clight
pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms.
- pkgver = 4.9
+ pkgver = 4.10
pkgrel = 1
url = https://github.com/FedeDP/Clight
install = clight.install
@@ -19,8 +19,17 @@ pkgbase = clight
optdepends = upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.
optdepends = bash-completion: to add support for bash automatic completion.
optdepends = clight-gui: Clight GUI written in Qt.
- backup = etc/default/clight.conf
- source = clight-4.9.tar.gz::https://github.com/FedeDP/Clight/archive/4.9.tar.gz
- sha256sums = 638696ee22a3a3340659db37d4e3c6fc2763eee9c8c2f7f227190ad9db7742db
+ backup = etc/clight/clight.conf
+ backup = etc/clight/modules.conf.d/backlight.conf
+ backup = etc/clight/modules.conf.d/daytime.conf
+ backup = etc/clight/modules.conf.d/dimmer.conf
+ backup = etc/clight/modules.conf.d/dpms.conf
+ backup = etc/clight/modules.conf.d/gamma.conf
+ backup = etc/clight/modules.conf.d/inhibit.conf
+ backup = etc/clight/modules.conf.d/keyboard.conf
+ backup = etc/clight/modules.conf.d/screen.conf
+ backup = etc/clight/modules.conf.d/sensor.conf
+ source = clight-4.10.tar.gz::https://github.com/FedeDP/Clight/archive/4.10.tar.gz
+ sha256sums = fa385472d3b055f94875930873fafbb225d4874793755bd3ec2bba6ef1b85871
pkgname = clight
diff --git a/PKGBUILD b/PKGBUILD
index 850622687796..49b9cbfa9f4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutantota dot com>
# Contributor: Federico Di Pierro <nierro92@gmail.com>
pkgname=clight
-pkgver=4.9
+pkgver=4.10
pkgrel=1
pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms."
arch=('x86_64' 'aarch64')
@@ -14,16 +14,16 @@ optdepends=('geoclue: to retrieve user location through geoclue.'
and to autocalibrate keyboard backlight.'
'bash-completion: to add support for bash automatic completion.'
'clight-gui: Clight GUI written in Qt.')
-backup=("etc/default/$pkgname.conf")
+backup=("etc/$pkgname/$pkgname.conf"
+ "etc/$pkgname/modules.conf.d"/{backlight,daytime,dimmer,dpms,gamma,inhibit,keyboard,screen,sensor}.conf)
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('638696ee22a3a3340659db37d4e3c6fc2763eee9c8c2f7f227190ad9db7742db')
+sha256sums=('fa385472d3b055f94875930873fafbb225d4874793755bd3ec2bba6ef1b85871')
build() {
cmake -B build -S Clight-$pkgver \
- -G "Unix Makefiles" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
-Wno-dev
cmake --build build
}
diff --git a/clight.install b/clight.install
index e525a677d63e..ef0833a1b58f 100644
--- a/clight.install
+++ b/clight.install
@@ -1,7 +1,7 @@
post_install() {
echo '--> By default, first matching webcam/als device and backlight interface are used.'
echo '--> Therefore, it should work out of the box even without any setup in most cases.'
- echo '--> For any customization, take a look at settings file placed in /etc/default/clight.conf.'
+ echo '--> For any customization, take a look at settings file placed in /etc/clight/clight.conf.'
echo '--> If you are not in a XDG compliant DE, remember to add clight to your autostart script.'
}