summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-22 11:51:22 +0200
committerXZS2016-04-22 11:51:22 +0200
commit1c45a87df1937ef2de252c9ff179e1f65286cf9a (patch)
tree7f8a8be2e8c9edab2bc2f263365ebe5e61dc166e
parentaec4b10469a9ee7b0e382ff9a42a0125b11d5237 (diff)
downloadaur-1c45a87df1937ef2de252c9ff179e1f65286cf9a.tar.gz
fix version comparison
Comparing the minor version to a string of minor and major will never succeed. Originally, a restriction on the current shell version was omitted for historical reasons - most packages did so when dependencies were defined manually. This now turns into a concious decision to - permit the usage of the extension in instable gnome-shell versions - the ones with odd minor version numbers - where incompatibilities are introduced gradually. - ease the transition from one stable gnome-shell version - the ones with even minor version numbers - to the next. In an ideal world, all extensions should have been updates before the update hits the repositories. But as Arch is quite more on the edge than developers of some of the extensions, this is not the case more often than not.
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 265d3bc0fb3d..74c5fcfef75f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,7 +50,7 @@ package_20_version() {
tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
depends+=("gnome-shell>=3.${compatibles[0]}")
local max="${compatibles[-1]}"
- if [ "3.$max" != $(
+ if [ "$max" != $(
gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
) ]; then
depends+=("gnome-shell<3.$((${max%%.*} + 1))")