summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-03-04 17:43:22 -0500
committerDaniel Moch2018-03-04 17:43:22 -0500
commit1c4786827d60a047961beebd7e27240ccb380d40 (patch)
tree39086dd0fc3c08a79a99f8f6fd805b09f13c9054
parent43b894c610cc94b55d0db22c7f76ef2efe9a2b3a (diff)
downloadaur-1c4786827d60a047961beebd7e27240ccb380d40.tar.gz
Add LICENSE
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6ea9aad5871..b47dd7b7d712 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-forecastio
pkgdesc = A thin Python Wrapper for the Dark Sky (formerly Forecast.io) weather API
pkgver = 1.3.5
- pkgrel = 1
+ pkgrel = 2
url = http://zeevgilovitz.com/python-forecast.io
arch = any
- license = BSD 2-clause
+ license = BSD
makedepends = python-setuptools
depends = python
depends = python-requests
diff --git a/PKGBUILD b/PKGBUILD
index 3e71fb71b03e..8073375d33ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=python-forecastio
pkgver=1.3.5
-pkgrel=1
+pkgrel=2
pkgdesc="A thin Python Wrapper for the Dark Sky (formerly Forecast.io) weather API"
url="http://zeevgilovitz.com/python-forecast.io"
-license=('BSD 2-clause')
+license=('BSD')
arch=('any')
depends=(
'python'
@@ -25,6 +25,7 @@ build() {
package() {
cd "$srcdir/${pkgname}-${pkgver}/"
python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim: ts=2 sts=2 sw=2 et ft=PKGBUILD