summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-06-29 12:06:55 -0400
committeracxz2022-06-29 12:06:55 -0400
commit1c856dddf3ba36a1728f6e9b9d10ac93dde6bbdd (patch)
tree50af3afadb9f872b2b8954f3b86b3af16df1c824
parent741a0f6e9b38738d96b1c38a9561cac74e1dc418 (diff)
downloadaur-1c856dddf3ba36a1728f6e9b9d10ac93dde6bbdd.tar.gz
upgpkg: ignition-common 4.5.1-1
upstream release upgpkg: ignition-common 4.5.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 8 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39ec6df7d0e0..a85c34e752c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ignition-common
pkgdesc = A collection of useful classes and functions for handling many command tasks. This includes parsing 3D mesh files, managing console output, and using PID controllers.
- pkgver = 4.5.0
- pkgrel = 4
+ pkgver = 4.5.1
+ pkgrel = 1
url = https://ignitionrobotics.org/libs/common
arch = any
groups = development
@@ -15,9 +15,7 @@ pkgbase = ignition-common
depends = libutil-linux
depends = gts
depends = ffmpeg
- source = https://github.com/ignitionrobotics/ign-common/archive/ignition-common4_4.5.0.tar.gz
- source = patch::https://github.com/ignitionrobotics/ign-common/pull/325.patch
- sha256sums = 0810d23af7ae16524f115e191e72df9de436e0809ade3d85bdee455bfa3f1aff
- sha256sums = 799d1c63658cfec9671f88fecd38fd6dc659f89c7c8004d8011e47ce8b5dafc2
+ source = https://github.com/ignitionrobotics/ign-common/archive/ignition-common4_4.5.1.tar.gz
+ sha256sums = 3c56894f01fdd4ab7d550d1cc815265bb87050549646d4a036b59380cb833075
pkgname = ignition-common
diff --git a/PKGBUILD b/PKGBUILD
index 8791afe3173a..8cf05c210e07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
# Contributor: Tim Rakowski <tim.rakowski@gmail.com>
pkgname=ignition-common
-pkgver=4.5.0
-pkgrel=4
+pkgver=4.5.1
+pkgrel=1
pkgdesc="A collection of useful classes and functions for handling many command tasks. This includes parsing 3D mesh files, managing console output, and using PID controllers."
arch=('any')
url="https://ignitionrobotics.org/libs/common"
@@ -12,31 +12,23 @@ depends=('ignition-math>=6' 'ignition-utils' 'tinyxml2' 'freeimage' 'libutil-lin
makedepends=('ignition-cmake>=2' 'util-linux')
optdepends=()
conflicts=()
-source=("https://github.com/ignitionrobotics/ign-common/archive/${pkgname}4_${pkgver}.tar.gz" "patch"::"https://github.com/ignitionrobotics/ign-common/pull/325.patch")
-sha256sums=('0810d23af7ae16524f115e191e72df9de436e0809ade3d85bdee455bfa3f1aff'
- '799d1c63658cfec9671f88fecd38fd6dc659f89c7c8004d8011e47ce8b5dafc2')
+source=("https://github.com/ignitionrobotics/ign-common/archive/${pkgname}4_${pkgver}.tar.gz")
+sha256sums=('3c56894f01fdd4ab7d550d1cc815265bb87050549646d4a036b59380cb833075')
_dir="gz-common-${pkgname}4_${pkgver}"
-prepare() {
- cd "${srcdir}/$_dir"/
- patch -p1 -i "${srcdir}/patch"
-}
-
build() {
cd "$srcdir/$_dir"
mkdir -p build
cd build
- # Configure build
cmake .. -Wno-dev \
-DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DBUILD_TESTING:BOOL=False
- # Compile
make
}