summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2018-10-14 22:24:20 -0400
committerDaniel M. Capella2018-10-14 22:24:20 -0400
commit1c8b9bba9619c9b2fd01ce1fc66f8d506f12bba3 (patch)
tree5fb628f78fd449add0185c8e09f0656a94ed3b92
parent267a4ea8b7fc18b82ef56140b3be5a11aa7a2ed0 (diff)
downloadaur-1c8b9bba9619c9b2fd01ce1fc66f8d506f12bba3.tar.gz
0.4.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd03f4fddee2..3b28bf25060e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jul 15 23:15:07 UTC 2018
+# Mon Oct 15 02:24:18 UTC 2018
pkgbase = hangups
pkgdesc = The first third-party instant messaging client for Google Hangouts
- pkgver = 0.4.5
+ pkgver = 0.4.6
pkgrel = 1
url = https://github.com/tdryer/hangups
arch = any
@@ -16,10 +16,8 @@ pkgbase = hangups
depends = python-reparser
depends = python-requests
depends = python-urwid
- source = https://files.pythonhosted.org/packages/source/h/hangups/hangups-0.4.5.tar.gz
- source = hangups-0.4.5.license::https://raw.githubusercontent.com/tdryer/hangups/v0.4.5/LICENSE
- sha512sums = e074f6b4243268b56e840f094083a3ed79c91509f28d372b21f19b28052b14e3ab0858fed17d36996752ae09c23903fdd029e7fad80024313a9e223e3f13a06f
- sha512sums = 6a0e0c135e55f027e3817ce181c7f5d73a3fd6f4c1ebe6bb28ab61352eeecdf1acdea78178ae6fe1eae8632d99e16e85c973e403644b7eac77c62dfc6c21eae9
+ source = https://files.pythonhosted.org/packages/source/h/hangups/hangups-0.4.6.tar.gz
+ sha512sums = 643f9a5073a06a4dc85c582e9dac7503d4da74a6b87f09357623ad298c8b097071cb59f89ed32d54e1235c14605d36768b5abbd069d879b19b405c281d033bc8
pkgname = hangups
diff --git a/PKGBUILD b/PKGBUILD
index 3539f5db96fa..b65be22e91bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Stunts <f.pinamartins@gmail.com>
pkgname=hangups
-pkgver=0.4.5
+pkgver=0.4.6
pkgrel=1
pkgdesc='The first third-party instant messaging client for Google Hangouts'
arch=('any')
@@ -11,15 +11,12 @@ license=('MIT')
depends=('python-aiohttp' 'python-appdirs' 'python-configargparse'
'python-mechanicalsoup' 'python-protobuf' 'python-readlike'
'python-reparser' 'python-requests' 'python-urwid')
-source=("https://files.pythonhosted.org/packages/source/h/hangups/hangups-$pkgver.tar.gz"
- "hangups-$pkgver.license::https://raw.githubusercontent.com/tdryer/hangups/v$pkgver/LICENSE")
-sha512sums=('e074f6b4243268b56e840f094083a3ed79c91509f28d372b21f19b28052b14e3ab0858fed17d36996752ae09c23903fdd029e7fad80024313a9e223e3f13a06f'
- '6a0e0c135e55f027e3817ce181c7f5d73a3fd6f4c1ebe6bb28ab61352eeecdf1acdea78178ae6fe1eae8632d99e16e85c973e403644b7eac77c62dfc6c21eae9')
+source=("https://files.pythonhosted.org/packages/source/h/hangups/hangups-$pkgver.tar.gz")
+sha512sums=('643f9a5073a06a4dc85c582e9dac7503d4da74a6b87f09357623ad298c8b097071cb59f89ed32d54e1235c14605d36768b5abbd069d879b19b405c281d033bc8')
prepare() {
cd hangups-$pkgver
sed -i 's/==/>=/g' setup.py
- sed -i 's/protobuf>=3.1.0,<3.2.0/protobuf>=3.1.0/' setup.py
}
build() {
@@ -30,7 +27,7 @@ build() {
package() {
cd hangups-$pkgver
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 ../hangups-$pkgver.license "$pkgdir"/usr/share/licenses/hangups/LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/hangups/LICENSE
}
# vim:set ts=2 sw=2 et: