summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatthiakl2022-04-28 00:54:50 +0200
committermatthiakl2022-04-28 18:15:54 +0200
commit1c9142dc87988377a199d601942c5fae95e01b6b (patch)
tree04883922bed4a3eacfaaca53f4aa75109e0160e8
parent180bb4b525acb31680de28c3c2133a10ad01ff60 (diff)
downloadaur-1c9142dc87988377a199d601942c5fae95e01b6b.tar.gz
Removed dependencies `doxygen` and `graphviz`, added optdepend `minizip`, updated pkgver creation and install paths
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f4bc60d2ab5..c68c94b40968 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = widelands-git
pkgdesc = An elaborate realtime multiplayer strategy game with emphasis on economy and transport - development version. In the spirit of BlueByte's 'Siedler II/ Settlers 2'.
- pkgver = 21+r24821_20200828_7f72ddf
- pkgrel = 6
+ pkgver = 1.1+git
+ pkgrel = 1
epoch = 0
url = http://widelands.org/
arch = aarch64
@@ -10,9 +10,7 @@ pkgbase = widelands-git
license = GPL2
makedepends = cmake
makedepends = coreutils
- makedepends = doxygen
makedepends = git
- makedepends = graphviz
makedepends = python
depends = asio
depends = gettext
@@ -23,11 +21,12 @@ pkgbase = widelands-git
depends = sdl2_mixer
depends = sdl2_ttf
depends = zlib
- provides = widelands=21+r24821_20200828_7f72ddf
+ optdepends = minizip: use system minizip instead of embedded one
+ provides = widelands=1.1+git
conflicts = widelands
conflicts = widelands-bzr
conflicts = widelands-data
- replaces = widelands-bzr<=21+r24821_20200828_7f72ddf
+ replaces = widelands-bzr<=1.1+git
options = !strip
source = widelands::git+https://github.com/widelands/widelands.git
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..14578b481b8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+widelands
+pkg
+src
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 3ff2ed4e3914..451bdc6748be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: dreieck
+# Maintainer: matthiakl <t-m · 42 _strange_curved_character_ mailpost · spdns · org>
+# Contributor: dreieck
# Contributor: Gabriel Margiani (gamag) <gabriel _strange_curved_character_ margiani · ch>
# Contributor: matthiaskrgr <matthias · krueger _strange_curved_character_ famsike · de>
@@ -6,8 +7,8 @@ _pkgname=widelands
pkgname="${_pkgname}-git"
epoch=0
_pkgver=latest
-pkgver=21+r24821_20200828_7f72ddf
-pkgrel=6
+pkgver=1.1+git25734_aa65c41_20220428
+pkgrel=1
pkgdesc="An elaborate realtime multiplayer strategy game with emphasis on economy and transport - development version. In the spirit of BlueByte's 'Siedler II/ Settlers 2'."
url="http://widelands.org/"
arch=(
@@ -30,12 +31,12 @@ depends=(
makedepends=(
'cmake' # For configuring the build
'coreutils' # For `nproc`
- 'doxygen' # For documentation (?)
'git' # For getting the source
- 'graphviz' # For documentation (?)
- 'python'
+ 'python' # For revision detection
+)
+optdepends=(
+ 'minizip: use system minizip instead of embedded one'
)
-optdepends=()
provides=(
"${_pkgname}=${pkgver}"
)
@@ -83,7 +84,7 @@ pkgver() {
cd "${srcdir}/${_pkgname}"
_get_build_ver() {
- grep -Ei 'build[[:space:]]+[0-9]+' "ChangeLog" | head -n 1 | sed -E 's|^.*[Bb]uild[[:space:]]+([0-9]+).*$|\1|'
+ cat NEXT_STABLE_VERSION
}
_get_git_commit_count() {
git rev-list --count HEAD
@@ -117,7 +118,7 @@ pkgver() {
return 14
fi
- printf "%s" "${_ver}+r${_rev}_${_date}_${_hash}"
+ printf "%s" "${_ver}+git${_rev}_${_hash}_${_date}"
}
@@ -159,7 +160,6 @@ build() {
fi
msg2 'Running `cmake` ...'
- # YES, -DCMAKE_INSTALL_PREFIX="/usr/bin" is corrent (nothing ${pkgdir}-related!!).
# If this failes on an existing build because of an mismatch of src and build cmake files, just delete build and try again.
cmake \
-DBUILD_TESTING=ON \
@@ -170,13 +170,12 @@ build() {
-DCMAKE_C_FLAGS_RELEASE="${CFLAGS} -DNDEBUG" \
-DCMAKE_EXE_LINKER_FLAGS="" \
-DCMAKE_EXE_LINKER_FLAGS_RELEASE="${LDFLAGS}" \
- -DCMAKE_INSTALL_PREFIX="/usr/bin" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_MODULE_LINKER_FLAGS="${LDFLAGS}" \
-DCMAKE_SHARED_LINKER_FLAGS="${LDFLAGS}" \
-DCMAKE_STATIC_LINKER_FLAGS="" \
-DGETTEXT_MSGFMT_EXECUTABLE=/usr/bin/msgfmt \
-DGETTEXT_MSGMERGE_EXECUTABLE=/usr/bin/msgmerge \
- -DICU_CONFIG_EXECUTABLE=/usr/bin/icu-config \
-DOPTION_ASAN=OFF \
-DOPTION_BUILD_CODECHECK=OFF \
-DOPTION_BUILD_TESTS=ON \
@@ -186,7 +185,9 @@ build() {
-DOPTION_USE_GLBINDING=OFF \
-DOpenGL_GL_PREFERENCE=LEGACY \
-DUSE_XDG=OFF \
+ -DWL_INSTALL_BASEDIR=/usr/share/doc/${_pkgname} \
-DWL_INSTALL_DATADIR=/usr/share/widelands \
+ -DWL_INSTALL_BINDIR=/usr/bin \
..
msg2 'Running `make` ...'
@@ -211,9 +212,6 @@ package() {
msg2 'Installing additional documentation files ...'
cd "${srcdir}/${_pkgname}"
- for _docfile in CREDITS ChangeLog; do
- install -D -v -m644 "${_docfile}" "${pkgdir}/usr/share/doc/${_pkgname}/${_docfile}"
- done
install -D -v -m644 "${srcdir}/${_gitlog}" "${pkgdir}/usr/share/doc/${_pkgname}/git-log.txt"
### When re-activating the following, also uncomment the line which sets ${_keep_translations[]}!