summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2019-10-22 00:59:08 +0800
committerKaizhao Zhang2019-10-22 00:59:08 +0800
commit1c9b1315a1581ded1c0f82317d4db0c8d43ef240 (patch)
treea4bd89ede86f12aca4f148570a629385413d1e14
parent6c88d2d798bb35150c514363d8c2b21e7dbc6028 (diff)
downloadaur-1c9b1315a1581ded1c0f82317d4db0c8d43ef240.tar.gz
Updated to version 0.23.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
-rw-r--r--no-adduserpath-now.patch10
3 files changed, 11 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aed54afdee7c..21fb215c4452 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = python-hatch
pkgdesc = A modern project, package, and virtual env manager
- pkgver = 0.20.0
+ pkgver = 0.23.0
pkgrel = 1
url = https://github.com/ofek/hatch
arch = any
license = MIT
license = APACHE
- depends = python>=3.6
+ depends = python>=3.5
depends = python-appdirs
depends = python-atomicwrites
depends = python-click
@@ -17,19 +17,18 @@ pkgbase = python-hatch
depends = python-pytest
depends = python-semver>=2.7.8
depends = python-setuptools>=36.0.0
+ depends = python-sortedcontainers>=1.5.7
depends = python-toml>=0.9.3
depends = twine>=1.9.1
- depends = python-userpath>=1.1.0
+ depends = python-userpath>=1.3.0
depends = python-virtualenv
depends = python-wheel>=0.27.0
provides = python-hatch
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/h/hatch/hatch-0.20.0.tar.gz
- source = no-adduserpath-now.patch
+ source = https://files.pythonhosted.org/packages/source/h/hatch/hatch-0.23.0.tar.gz
source = hatch_complete.sh
source = hatch_complete.zsh
- sha256sums = dddbc0e141dfcdc69f3c632515469b44d8610674abc52558d96dd4b7a9fa1382
- sha256sums = 88999bb69dfcff6221a705b8383c793e757483dff2b7b002bd7b9c0abbe3c3c5
+ sha256sums = b4b65753fcd8319ebddd51c0e1ef148d09592cdc38923d032f8f58ffc1658fd7
sha256sums = b87254c621719188907a2062b0aa3c4eb078088872d1de7d53d6a6d61a679c44
sha256sums = a43679d72ebb7b5c029192519597eff835586d0b6ed9d1e3dfc93270b8720e71
diff --git a/PKGBUILD b/PKGBUILD
index 97cc176da5be..21b5c8ae44b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
_name=hatch
-_sha256sum=dddbc0e141dfcdc69f3c632515469b44d8610674abc52558d96dd4b7a9fa1382
+_sha256sum=b4b65753fcd8319ebddd51c0e1ef148d09592cdc38923d032f8f58ffc1658fd7
pkgname=python-hatch
-pkgver=0.20.0
+pkgver=0.23.0
pkgrel=1
pkgdesc="A modern project, package, and virtual env manager"
arch=('any')
url="https://github.com/ofek/hatch"
license=('MIT' 'APACHE')
depends=(
- 'python>=3.6'
+ 'python>=3.5'
'python-appdirs'
'python-atomicwrites'
'python-click'
@@ -22,9 +22,10 @@ depends=(
'python-pytest'
'python-semver>=2.7.8'
'python-setuptools>=36.0.0'
+ 'python-sortedcontainers>=1.5.7'
'python-toml>=0.9.3'
'twine>=1.9.1'
- 'python-userpath>=1.1.0'
+ 'python-userpath>=1.3.0'
'python-virtualenv'
'python-wheel>=0.27.0'
)
@@ -32,25 +33,15 @@ provides=('python-hatch')
options=(!emptydirs)
source=(
"https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz"
- 'no-adduserpath-now.patch'
'hatch_complete.sh'
'hatch_complete.zsh'
)
sha256sums=(
"${_sha256sum}"
- '88999bb69dfcff6221a705b8383c793e757483dff2b7b002bd7b9c0abbe3c3c5'
'b87254c621719188907a2062b0aa3c4eb078088872d1de7d53d6a6d61a679c44'
'a43679d72ebb7b5c029192519597eff835586d0b6ed9d1e3dfc93270b8720e71'
)
-prepare() {
- cd "${srcdir}/${_name}-${pkgver}"
- patch -p0 -i ../no-adduserpath-now.patch
-
- # no need to include tests files
- rm tests/__init__.py
-}
-
build() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
diff --git a/no-adduserpath-now.patch b/no-adduserpath-now.patch
deleted file mode 100644
index ad8a15c2653b..000000000000
--- a/no-adduserpath-now.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- setup.py.orig 2019-10-20 17:15:00.730064609 +0800
-+++ setup.py 2019-10-20 17:15:07.896906249 +0800
-@@ -52,7 +52,6 @@
- ),
-
- install_requires=(
-- 'adduserpath>=0.4.0',
- 'appdirs',
- 'atomicwrites',
- 'click',