summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-09-27 14:43:36 -0400
committerChris Severance2018-09-27 14:43:36 -0400
commit1cae86bdfd931b0475ed23b027b12ed6f5cf31d6 (patch)
tree72384caa2f926554ba6f3f04d5fd8389956c56a5
parent721eab459351a7863f099d889ca68c779bf35ef2 (diff)
downloadaur-1cae86bdfd931b0475ed23b027b12ed6f5cf31d6.tar.gz
autu: Update to 1.0.3.r35.g6d280f5-1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD69
-rw-r--r--README.md7
4 files changed, 56 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4097e424ec90..fe8fdc713b96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jul 8 19:11:55 UTC 2016
+# Thu Sep 27 18:43:36 UTC 2018
pkgbase = csvkit-git
pkgdesc = A suite of utilities for converting to and working with CSV.
- pkgver = 0.9.1.r319.gea1e7bb
- pkgrel = 4
+ pkgver = 1.0.3.r35.g6d280f5
+ pkgrel = 1
url = http://csvkit.readthedocs.org
arch = any
license = MIT
@@ -11,14 +11,18 @@ pkgbase = csvkit-git
makedepends = python-setuptools
makedepends = python-pip
depends = python
- depends = python-dateutil
- depends = python-sqlalchemy
- depends = python-six
depends = python-agate
- depends = python-agate-excel
depends = python-agate-dbf
+ depends = python-agate-excel
+ depends = python-agate-sql
+ depends = python-dateutil
+ depends = python-six
+ depends = python-sqlalchemy
+ provides = csvkit=1.0.3
+ conflicts = csvkit
source = csvkit::git://github.com/wireservice/csvkit.git
md5sums = SKIP
+ sha256sums = SKIP
pkgname = csvkit-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index f758791f2a7e..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,12 +0,0 @@
-# Package created by makepkg
-/csvkit-git-*.xz
-
-# Cloned by makepkg
-/csvkit/
-/agate/
-/agate-excel/
-/agate-dbf/
-
-# Created by makepkg
-/src/
-/pkg/
diff --git a/PKGBUILD b/PKGBUILD
index f5b33d286453..1a4c4800e7ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,67 @@
-# Maintainer: Alexander Kurilo <alex@kurilo.me>
+# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
+# Contributor: Alexander Kurilo <alex@kurilo.me>
# Contributor: Mariusz Szczepańczyk <mszczepanczyk@gmail.com>
# Contributor: Thor K. H. <thor alfakrøll roht dott no>
-pkgname=csvkit-git
-pkgver=0.9.1.r319.gea1e7bb
-pkgrel=4
+set -u
+_pkgname='csvkit'
+pkgname="${_pkgname}-git"
+pkgver=1.0.3.r35.g6d280f5
+pkgrel=1
pkgdesc="A suite of utilities for converting to and working with CSV."
arch=('any')
-url="http://csvkit.readthedocs.org"
+url='http://csvkit.readthedocs.org'
license=('MIT')
depends=(
- 'python'
- 'python-dateutil' # >=2.2
- 'python-sqlalchemy' # >=0.9.3
- 'python-six' # >=1.6.1
- 'python-agate' # >= 1.2.2
- 'python-agate-excel' # >= 0.1.0
- 'python-agate-dbf' # >= 0.1.0
+ 'python'
+ 'python-agate' # >= 1.2.2
+ 'python-agate-dbf' # >= 0.1.0
+ 'python-agate-excel' # >= 0.1.0
+ 'python-agate-sql'
+ 'python-dateutil' # >=2.2
+ 'python-six' # >=1.6.1
+ 'python-sqlalchemy' # >=0.9.3
)
makedepends=(
- 'git'
- 'python-setuptools'
- 'python-pip'
+ 'git'
+ 'python-setuptools'
+ 'python-pip'
)
-md5sums=('SKIP')
+provides=("${_pkgname}=${pkgver%%.r*}")
+conflicts=("${_pkgname}")
+_srcdir='csvkit'
source=('csvkit::git://github.com/wireservice/csvkit.git')
+md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/csvkit"
+ set -u
+ cd "${_srcdir}"
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ set +u
}
-build() {
- cd "$srcdir/csvkit"
+prepare() {
+ set -u
+ cd "${_srcdir}"
# Quick and dirty fix until the author officially supports dateutil>=2.2
# (see https://github.com/onyxfish/csvkit/issues/370)
- sed -i 's/python-dateutil==2.2/python-dateutil>=2.2/' setup.py
- sed -i 's/openpyxl==2.2.0-b1/openpyxl>=2.2.0-b1/' setup.py
+ #sed -i 's/python-dateutil==2.2/python-dateutil>=2.2/' setup.py
+ #sed -i 's/openpyxl==2.2.0-b1/openpyxl>=2.2.0-b1/' setup.py
+ set +u
}
-package() {
- cd "$srcdir/csvkit"
- python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ set -u
+ cd "${_srcdir}"
+ python setup.py build
+ set +u
}
+package() {
+ set -u
+ cd "${_srcdir}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ set +u
+}
+set +u
diff --git a/README.md b/README.md
deleted file mode 100644
index f976bda84553..000000000000
--- a/README.md
+++ /dev/null
@@ -1,7 +0,0 @@
-[csvkit-git for AUR](https://aur.archlinux.org/packages/csvkit-git/)
-
-[This repository](https://github.com/kamazee/aur-csvkit-git) mirrors [AUR
-repository](https://aur.archlinux.org/cgit/aur.git/log/?h=csvkit-git) and
-enables pull requests
-
-Original PKGBUILD is created by [Mariusz Szczepańczyk](https://github.com/mszczepanczyk)