summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Arthaud2019-06-12 10:21:08 -0700
committerMaxime Arthaud2019-06-12 10:21:08 -0700
commit1cf6bcd039530d9360f8a2e28a7b752111eb74c9 (patch)
tree14eea5bbc0a2f1e400e42345bf3118dd0ac8dfc5
downloadaur-1cf6bcd039530d9360f8a2e28a7b752111eb74c9.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD58
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6076e5a4098
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = ikos-git
+ pkgdesc = Static analyzer for C and C++ developed by NASA
+ pkgver = 2.1.r237.bf4ac4a
+ pkgrel = 1
+ url = https://github.com/nasa-sw-vnv/ikos
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = custom:NOSA 1.3
+ makedepends = cmake
+ makedepends = boost
+ depends = gmp
+ depends = boost-libs
+ depends = python
+ depends = python-pygments
+ depends = sqlite
+ depends = llvm
+ depends = llvm-libs
+ depends = clang
+ depends = apron
+ provides = ikos
+ source = ikos-git::git://github.com/nasa-sw-vnv/ikos.git
+ sha256sums = SKIP
+
+pkgname = ikos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ae3b464f0e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Maxime Arthaud <maxime@arthaud.me>
+
+pkgname=ikos-git
+pkgver=2.1.r237.bf4ac4a
+pkgrel=1
+pkgdesc='Static analyzer for C and C++ developed by NASA'
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url='https://github.com/nasa-sw-vnv/ikos'
+license=('custom:NOSA 1.3')
+provides=('ikos')
+depends=('gmp'
+ 'boost-libs'
+ 'python'
+ 'python-pygments'
+ 'sqlite'
+ 'llvm'
+ 'llvm-libs'
+ 'clang'
+ 'apron')
+makedepends=('cmake'
+ 'boost')
+source=("$pkgname::git://github.com/nasa-sw-vnv/ikos.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "%s.r%s.%s" \
+ "$(git describe --tags --abbrev=0 | sed 's/^v//')" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ mkdir build
+}
+
+build() {
+ cd "$srcdir/$pkgname/build"
+ cmake \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DLLVM_CONFIG_EXECUTABLE="/usr/bin/llvm-config" \
+ -DAPPEND_GIT_VERSION=ON \
+ ..
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/build"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/$pkgname/LICENSE.pdf" "$pkgdir/usr/share/licenses/ikos/LICENSE"
+}
+
+check() {
+ cd "$srcdir/$pkgname/build"
+ make check
+}