summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2018-11-14 20:36:56 +0300
committerBuildTools2018-11-14 20:36:56 +0300
commit1cf90173d5ced76a15cef8b5af5cb4e12633023e (patch)
tree721e0810b66af8f611a270cfae58953d8684ce45
parent79304c7c25663dc5c5d685689e54fea6c6915df2 (diff)
downloadaur-1cf90173d5ced76a15cef8b5af5cb4e12633023e.tar.gz
1.10.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f774be8df73c..eec9c6f16692 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Nov 14 17:32:37 UTC 2018
+# Wed Nov 14 17:36:51 UTC 2018
pkgbase = yandex-disk-indicator
pkgdesc = Panel indicator (GUI) for YandexDisk CLI client for Linux.
pkgver = 1.10.5
pkgrel = 2
- url = https://github.com/slytomcat/yandex-disk-indicator
+ url = https://github.com/slytomcat/yandex-disk-indicator/
arch = i686
arch = x86_64
license = GPL3
@@ -16,8 +16,8 @@ pkgbase = yandex-disk-indicator
depends = libappindicator-gtk3
depends = xclip
depends = zenity
- source = https://github.com/slytomcat/yandex-disk-indicator/archive/1.10.5.tar.gz
- md5sums = 9886dff3c9407c893d2008debe7a2145
+ source = yandex-disk-indicator::git+https://github.com/slytomcat/yandex-disk-indicator.git
+ sha1sums = SKIP
pkgname = yandex-disk-indicator
diff --git a/PKGBUILD b/PKGBUILD
index 703c62ec0459..b32ae55acfb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,23 @@
pkgname='yandex-disk-indicator'
pkgver=1.10.5
pkgrel=2
-pkgdesc='Panel indicator (GUI) for YandexDisk CLI client for Linux.'
+pkgdesc="Panel indicator (GUI) for YandexDisk CLI client for Linux."
arch=('i686' 'x86_64')
-url='https://github.com/slytomcat/yandex-disk-indicator'
+url="https://github.com/slytomcat/${pkgname}/"
license=('GPL3')
depends=('yandex-disk' 'python' 'python-pyinotify' 'pygobject-devel' 'python-gobject' 'libappindicator-gtk3' 'xclip' 'zenity')
-source=("https://github.com/slytomcat/yandex-disk-indicator/archive/${pkgver}.tar.gz")
-md5sums=('9886dff3c9407c893d2008debe7a2145')
+source=("$pkgname::git+https://github.com/slytomcat/${pkgname}.git")
+sha1sums=('SKIP')
-package() {
- cd $srcdir
- bsdtar xf ${pkgver}.tar.gz
- cd ${pkgname}-${pkgver}/build
- ./prepare.sh
+prepare() {
+ cd $pkgname/build
+ chmod +x prepare.sh
+}
+package() {
mkdir $pkgdir/usr
- cp -r yd-tools/usr/* $pkgdir/usr
+ cd $pkgname/build
+ export TARGET="$pkgdir/usr"
+ sh prepare.sh
}