summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2022-04-18 04:41:52 +0200
committerMuflone2022-04-18 04:41:52 +0200
commit1cfd46621f9ec37cacd2d8969fed23ff4ce6f79f (patch)
treebede7561629b6d10435d33d7fa857651f6224ef1
parent3c7eae07883d93c1f6b9fc23685a099c3d045427 (diff)
downloadaur-1cfd46621f9ec37cacd2d8969fed23ff4ce6f79f.tar.gz
Updated package gextractwinicons-git 0.5.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rw-r--r--gextractwinicons-git.install14
3 files changed, 17 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 284a2835fb7a..55d94c0a19ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = gextractwinicons-git
pkgdesc = Extract cursors and icons from MS Windows compatible resource files
- pkgver = 0.4.2.g77d95e2
+ pkgver = 0.5.0
pkgrel = 1
- url = http://url.muflone.com/gextractwinicons
- install = gextractwinicons-git.install
+ url = https://www.muflone.com/gextractwinicons
arch = any
- license = GPL2
+ license = GPL3
makedepends = git
+ makedepends = python-setuptools
+ makedepends = gettext
depends = gtk3
depends = gobject-introspection
- depends = python2-xdg
- depends = python2-gobject
- depends = gtk-update-icon-cache
+ depends = python-xdg
+ depends = python-gobject
depends = icoutils
provides = gextractwinicons
conflicts = gextractwinicons
source = git+https://github.com/muflone/gextractwinicons.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = gextractwinicons-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 189ceffca09d..77de474a8f1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
-# Maintainer: Muflone http://url.muflone.com/contacts
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=gextractwinicons-git
-pkgver=0.4.2.g77d95e2
+pkgver=0.5.0
pkgrel=1
pkgdesc="Extract cursors and icons from MS Windows compatible resource files"
-url="http://url.muflone.com/gextractwinicons"
+url="https://www.muflone.com/gextractwinicons"
arch=('any')
-license=('GPL2')
-depends=('gtk3' 'gobject-introspection' 'python2-xdg' 'python2-gobject' 'gtk-update-icon-cache' 'icoutils')
-makedepends=('git')
+license=('GPL3')
+makedepends=('git' 'python-setuptools' 'gettext')
+depends=('gtk3' 'gobject-introspection' 'python-xdg' 'python-gobject' 'icoutils')
provides=('gextractwinicons')
conflicts=('gextractwinicons')
source=("git+https://github.com/muflone/gextractwinicons.git")
-md5sums=('SKIP')
-install="${pkgname}.install"
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-*}"
@@ -22,11 +21,11 @@ pkgver() {
build() {
cd "${pkgname%-*}"
- python2 setup.py build
+ python3 setup.py build
}
package() {
cd "${pkgname%-*}"
- python2 setup.py install --optimize=1 --root "${pkgdir}"
+ python3 setup.py install --optimize=1 --root "${pkgdir}"
}
diff --git a/gextractwinicons-git.install b/gextractwinicons-git.install
deleted file mode 100644
index a02985b5a2db..000000000000
--- a/gextractwinicons-git.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q /usr/share/icons/hicolor/
- xdg-icon-resource forceupdate
- xdg-desktop-menu forceupdate
-}
-
-post_update() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-