summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCork2020-10-09 19:59:51 +0200
committerCork2020-10-09 19:59:51 +0200
commit1d4b5bb7159007c3dab84ccf03adda00e9d61904 (patch)
treef1ecf3053608a4115ceff7f6bafa3e8e3f2cdda1
parent5dbff4c5f9554bc1bfc61b09d0f946ce7e392853 (diff)
downloadaur-1d4b5bb7159007c3dab84ccf03adda00e9d61904.tar.gz
Update to new launch name for the commandline
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--default-to-fast-bios.patch52
3 files changed, 32 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11a1200109b6..068070b5070a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dosbox-x-fast-bios-git
pkgdesc = x86 emulator with builtin DOS, with patches with more features, with fastbios on by default
- pkgver = 9792.c9d907301
+ pkgver = 12155.c5496a1a0
pkgrel = 1
url = http://dosbox.sourceforge.net
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 0aa8c8083152..839bb6cc8e9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Mantainer: Cork
pkgname=dosbox-x-fast-bios-git
-pkgver=9792.c9d907301
+pkgver=12155.c5496a1a0
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features, with fastbios on by default"
arch=(i686 x86_64)
@@ -37,7 +37,7 @@ package() {
"$pkgdir/usr/share/applications/dosbox-x.desktop"
}
-md5sums=('SKIP'
- '72303aba7f3d1ad98f81910124350f44'
- '3dcfe45c5ed0433316eaea51e3620b36'
- '615228a51b52d4788c73940602f1dc97')
+sha256sums=('SKIP'
+ '4597633a842e60243bd190dbd36f613951aceeb1bd75f3af6229f60ade58f926'
+ 'caa164f3d17d414733882d29098cb9cd63faddbdd5580a0c30f1173a63c42475'
+ '32f290580ec02dedd09908d8a4de10f57b94998f2c1eb597b649208cd87b2d33')
diff --git a/default-to-fast-bios.patch b/default-to-fast-bios.patch
index 4f96e6951b72..c51748ef902b 100644
--- a/default-to-fast-bios.patch
+++ b/default-to-fast-bios.patch
@@ -1,37 +1,37 @@
diff --git a/include/control.h b/include/control.h
-index 398b8ad15..c3ddf2eae 100644
+index f99ababd8..fcd5e54d4 100644
--- a/include/control.h
+++ b/include/control.h
-@@ -93,7 +93,7 @@ public:
- opt_erasemapper = false;
- opt_resetmapper = false;
- opt_startmapper = false;
-- opt_fastbioslogo = false;
-+ opt_fastbioslogo = true;
- opt_alt_vga_render = false;
- opt_date_host_forced = false;
- opt_disable_numlock_check = false;
+@@ -87,7 +87,7 @@ public:
+ opt_printconf = false;
+ opt_noautoexec = false;
+ opt_securemode = false;
+- opt_fastlaunch = false;
++ opt_fastlaunch = true;
+ opt_fullscreen = false;
+ opt_showcycles = false;
+ opt_earlydebug = false;
diff --git a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
-index 8d1476320..e7a41d8a4 100644
+index a54b9a3e2..b25f865ee 100644
--- a/src/gui/sdlmain.cpp
+++ b/src/gui/sdlmain.cpp
-@@ -6258,7 +6258,7 @@ bool DOSBOX_parse_argv() {
- fprintf(stderr," Make sure to surround the command in quotes to cover spaces.\n");
- fprintf(stderr," -break-start Break into debugger at startup\n");
+@@ -6953,7 +6953,7 @@ bool DOSBOX_parse_argv() {
+ fprintf(stderr," -set <section property=value> Set the config option (overriding the config file).\n");
+ fprintf(stderr," Make sure to surround the string in quotes to cover spaces.\n");
fprintf(stderr," -time-limit <n> Kill the emulator after 'n' seconds\n");
-- fprintf(stderr," -fastbioslogo Fast BIOS logo (skip 1-second pause)\n");
-+ fprintf(stderr," -bioslogo Show BIOS logo (1-second pause)\n");
- fprintf(stderr," -log-con Log CON output to a log file\n");
- fprintf(stderr," -log-int21 Log calls to INT 21h (debug level)\n");
- fprintf(stderr," -log-fileio Log file I/O through INT 21h (debug level)\n");
-@@ -6332,8 +6332,8 @@ bool DOSBOX_parse_argv() {
- else if (optname == "lang") {
- if (!control->cmdline->NextOptArgv(control->opt_lang)) return false;
+- fprintf(stderr," -fastlaunch Fast launch mode (skip the BIOS logo and welcome banner)\n");
++ fprintf(stderr," -launchlogo Show launch logo (show the launch logo and welcome banner)\n");
+ #if C_DEBUG
+ fprintf(stderr," -helpdebug Show debug-related options\n");
+ #endif
+@@ -7074,8 +7074,8 @@ bool DOSBOX_parse_argv() {
+ else if (optname == "fastbioslogo") {
+ control->opt_fastbioslogo = true;
}
-- else if (optname == "fastbioslogo") {
-- control->opt_fastbioslogo = true;
-+ else if (optname == "bioslogo") {
-+ control->opt_fastbioslogo = false;
+- else if (optname == "fastlaunch") {
+- control->opt_fastlaunch = true;
++ else if (optname == "launchlogo") {
++ control->opt_fastlaunch = false;
}
else if (optname == "conf") {
if (!control->cmdline->NextOptArgv(tmp)) return false;