summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvador Pardiñas2017-06-04 08:20:03 -0300
committerSalvador Pardiñas2017-06-04 08:20:03 -0300
commit1d73d7be58861fe115cff82d9aa5e48c42225874 (patch)
treeafe9489224d4756166ec9a738c756fd7dd549a05
downloadaur-1d73d7be58861fe115cff82d9aa5e48c42225874.tar.gz
Initial Commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--allow_root.patch16
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7c0544771df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = higan-git
+ pkgdesc = Multisystem emulator by Byuu
+ pkgver = r572.1ca46090
+ pkgrel = 1
+ url = https://byuu.org
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ depends = libpulse
+ depends = gtksourceview2
+ depends = sdl
+ depends = libxv
+ depends = libao
+ depends = openal
+ provides = higan
+ conflicts = higan
+ source = git+https://gitlab.com/higan/higan.git
+ source = allow_root.patch
+ md5sums = SKIP
+ md5sums = 6bc32fa73fafec579fcc608feed43523
+
+pkgname = higan-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24bb3a54af43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Salvador Pardiñas <darkfm@vera.com.uy>
+pkgname=higan-git
+pkgver=r572.1ca46090
+pkgrel=1
+pkgdesc="Multisystem emulator by Byuu"
+arch=('x86_64' 'i686')
+url="https://byuu.org"
+license=('GPL3')
+groups=()
+depends=('libpulse' 'gtksourceview2' 'sdl' 'libxv' 'libao' 'openal')
+makedepends=('git')
+provides=('higan')
+conflicts=('higan')
+replaces=()
+backup=()
+options=()
+source=(
+ 'git+https://gitlab.com/higan/higan.git'
+ 'allow_root.patch')
+noextract=()
+md5sums=('SKIP'
+ '6bc32fa73fafec579fcc608feed43523')
+
+prepare() {
+ cd $srcdir/higan
+ patch -Np1 -i "${srcdir}/allow_root.patch"
+}
+
+pkgver() {
+ cd "$srcdir/higan"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/higan"
+ make -C icarus compiler=g++
+ make -C higan compiler=g++
+}
+
+package() {
+ cd "$srcdir/higan"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ make -C icarus prefix="$pkgdir/usr" install
+ make -C higan prefix="$pkgdir/usr" install
+ chmod -R 777 "$pkgdir/usr/share/higan"
+ chmod -R 777 "$pkgdir/usr/share/icarus"
+}
diff --git a/allow_root.patch b/allow_root.patch
new file mode 100644
index 000000000000..03c133761d7f
--- /dev/null
+++ b/allow_root.patch
@@ -0,0 +1,16 @@
+diff -ura higan/higan/target-tomoko/GNUmakefile higan_new/higan/target-tomoko/GNUmakefile
+--- higan/higan/target-tomoko/GNUmakefile 2017-06-03 19:31:12.084743578 -0300
++++ higan_new/higan/target-tomoko/GNUmakefile 2017-06-03 19:29:25.234742810 -0300
+@@ -78,9 +78,9 @@
+ endif
+
+ install:
+-ifeq ($(shell id -un),root)
+- $(error "make install should not be run as root")
+-else ifeq ($(platform),windows)
++#ifeq ($(shell id -un),root)
++# $(error "make install should not be run as root")
++ifeq ($(platform),windows)
+ else ifeq ($(platform),macosx)
+ mkdir -p ~/Library/Application\ Support/$(name)/
+ mkdir -p ~/Emulation/System/