summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-12-27 21:01:49 -0500
committerMario Finelli2016-12-27 21:01:49 -0500
commit1db7980b894d04b4b0e0fb952c9056e4c48ea2e5 (patch)
tree9318731e63100a4a19d7242e0e7a71b74d1abafe
downloadaur-1db7980b894d04b4b0e0fb952c9056e4c48ea2e5.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..245b0e86439a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Dec 28 02:01:41 UTC 2016
+pkgbase = ruby-hanami-mailer
+ pkgdesc = Mail for Ruby applications and Hanami mailers.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://hanamirb.org/
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-hanami-utils
+ depends = ruby-mail
+ depends = ruby-tilt
+ noextract = hanami-mailer-0.4.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/hanami-mailer-0.4.0.gem
+ sha256sums = 94c2adb8ff1db6e5316d8ad0a16696c58e9522dbb652aa7d0d0155f187cc6fa0
+
+pkgname = ruby-hanami-mailer
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09f075db2b4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+_gemname=hanami-mailer
+pkgname=ruby-$_gemname
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Mail for Ruby applications and Hanami mailers.'
+arch=(any)
+url='http://hanamirb.org/'
+license=(MIT)
+depends=(ruby ruby-hanami-utils ruby-mail ruby-tilt)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('94c2adb8ff1db6e5316d8ad0a16696c58e9522dbb652aa7d0d0155f187cc6fa0')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}