summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDJ Lucas2015-07-17 20:21:54 -0500
committerDJ Lucas2015-07-17 20:21:54 -0500
commit1dc5e77943d858f2975f6c034c42734ed0d8b03c (patch)
tree8055f4e2871359bdb59564ccb15571ca19506c44
downloadaur-1dc5e77943d858f2975f6c034c42734ed0d8b03c.tar.gz
Initial commit
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD83
-rw-r--r--UI_MailPartViewers_GNUmakefile.patch31
-rw-r--r--sogo.install9
-rw-r--r--sogo.service11
-rw-r--r--sogo_configure.patch14
6 files changed, 200 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33ab3d7523ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,52 @@
+pkgbase = sogo
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = http://www.sogo.nu/
+ install = sogo.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-base
+ makedepends = libwbxml
+ makedepends = libmemcached
+ makedepends = sope>=2.3.0
+ options = !strip
+ source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-2.3.0.tar.gz
+ source = sogo_configure.patch
+ source = UI_MailPartViewers_GNUmakefile.patch
+ source = sogo.service
+ sha256sums = 26134eee48b6a42b047fea61a093b7774bf5066778debf02bcff6f6682803e0a
+ sha256sums = e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1
+ sha256sums = ef6ab2829d35c2abb5529ee8ea9a4cc541913b0a82bc91f4c9fa21c65d44a4aa
+ sha256sums = 62a22aa4231059fd85315795ea735638da4bc71cde4c7da21a71f2559647a4b1
+
+pkgname = sogo
+ pkgdesc = groupware server built around OpenGroupware.org (OGo) and the SOPE application server
+ depends = sope>=2.3.0
+ depends = gnustep-base
+ depends = libmemcached
+ depends = memcached
+ optdepends = postgresql: run database server for sogo locally
+ optdepends = mariadb: run database server for sogo locally
+ optdepends = openldap: run directory server for sogo locally
+ optdepends = postfix: run smtp server for sogo locally
+ optdepends = dovecot: run imap server for sogo locally
+ optdepends = courier-imap: run imap server for sogo locally
+ optdepends = nginx: webserver to provide web interface locally
+ optdepends = apache: webserver to provide web interface locally
+ optdepends = lighttpd: webserver to provide web interface locally
+ optdepends = funambol: sync mobile devices with sogo contacts, events, tasks via SyncML
+ backup = etc/sogo/sogo.conf
+ backup = etc/httpd/conf/extra/SOGo.conf
+
+pkgname = sogo-openchange
+ pkgdesc = OpenChange module for SOGo
+ depends = sogo=2.3.0
+ depends = openchange
+
+pkgname = sogo-activesync
+ pkgdesc = ActiveSync module for SOGo
+ depends = sogo=2.3.0
+ depends = libwbxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d50217023e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,83 @@
+# Maintainer: DJ Lucas <dj@linuxfromscratch.org>
+# Maintainer: Steven Hiscocks <steven [at] hiscocks [dot] me [dot] uk>
+# Contributor: Andre Wayand <aur-sogo@awayand.sleepmail.com>
+pkgbase=sogo
+pkgname=('sogo'
+ 'sogo-openchange'
+ 'sogo-activesync')
+pkgver=2.3.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.sogo.nu/"
+license=('GPL')
+makedepends=('gcc-objc'
+ 'gnustep-base'
+ 'libwbxml'
+ 'libmemcached'
+ 'sope>=2.3.0')
+options=('!strip')
+install=sogo.install
+source=(
+ http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz
+ sogo_configure.patch
+ UI_MailPartViewers_GNUmakefile.patch
+ sogo.service
+)
+
+prepare() {
+ cd "$srcdir/SOGo-${pkgver}"
+ patch configure ../sogo_configure.patch
+ patch -p1 < ../UI_MailPartViewers_GNUmakefile.patch
+}
+
+build() {
+ cd "$srcdir/SOGo-${pkgver}"
+ ./configure --prefix=$(gnustep-config --variable=GNUSTEP_SYSTEM_ROOT) --disable-debug
+ make
+}
+
+package_sogo() {
+pkgdesc="groupware server built around OpenGroupware.org (OGo) and the SOPE application server"
+depends=('sope>=2.3.0' 'gnustep-base' 'libmemcached' 'memcached')
+optdepends=(
+ 'postgresql: run database server for sogo locally'
+ 'mariadb: run database server for sogo locally'
+ 'openldap: run directory server for sogo locally'
+ 'postfix: run smtp server for sogo locally'
+ 'dovecot: run imap server for sogo locally'
+ 'courier-imap: run imap server for sogo locally'
+ 'nginx: webserver to provide web interface locally'
+ 'apache: webserver to provide web interface locally'
+ 'lighttpd: webserver to provide web interface locally'
+ 'funambol: sync mobile devices with sogo contacts, events, tasks via SyncML')
+backup=(etc/sogo/sogo.conf etc/httpd/conf/extra/SOGo.conf)
+
+ cd "${srcdir}/SOGo-${pkgver}"
+ make install DESTDIR="${pkgdir}" GNUSTEP_SYSTEM_ADMIN_TOOLS="/usr/bin"
+ install -D -m 0644 "${srcdir}"/sogo.service "${pkgdir}"/usr/lib/systemd/system/sogo.service
+ install -D -m 0600 "${srcdir}"/SOGo-${pkgver}/Scripts/sogo.conf "${pkgdir}"/etc/sogo/sogo.conf
+ install -D -m 0644 "${srcdir}"/SOGo-${pkgver}/Apache/SOGo.conf "${pkgdir}"/etc/httpd/conf/extra/SOGo.conf
+}
+
+package_sogo-openchange() {
+pkgdesc="OpenChange module for SOGo"
+depends=('sogo=2.3.0' 'openchange')
+
+ cd "${srcdir}/SOGo-${pkgver}/OpenChange"
+ sed 's@-Wall@-Wall -fobjc-exceptions@' -i GNUmakefile
+ make PYTHON=/usr/bin/python2 install DESTDIR="${pkgdir}" GNU_SYSTEM_ADMIN_TOOLS="/usr/bin"
+}
+
+package_sogo-activesync() {
+pkgdesc="ActiveSync module for SOGo"
+depends=('sogo=2.3.0' 'libwbxml')
+
+ cd "${srcdir}/SOGo-${pkgver}/ActiveSync"
+ make PYTHON=/usr/bin/python2 install DESTDIR="${pkgdir}" GNU_SYSTEM_ADMIN_TOOLS="/usr/bin"
+}
+
+sha256sums=('26134eee48b6a42b047fea61a093b7774bf5066778debf02bcff6f6682803e0a'
+ 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
+ 'ef6ab2829d35c2abb5529ee8ea9a4cc541913b0a82bc91f4c9fa21c65d44a4aa'
+ '62a22aa4231059fd85315795ea735638da4bc71cde4c7da21a71f2559647a4b1')
+
diff --git a/UI_MailPartViewers_GNUmakefile.patch b/UI_MailPartViewers_GNUmakefile.patch
new file mode 100644
index 000000000000..f9c884f87313
--- /dev/null
+++ b/UI_MailPartViewers_GNUmakefile.patch
@@ -0,0 +1,31 @@
+diff --git a/UI/MailPartViewers/GNUmakefile b/UI/MailPartViewers/GNUmakefile
+index a094e92..c82bf6f 100644
+--- a/UI/MailPartViewers/GNUmakefile
++++ b/UI/MailPartViewers/GNUmakefile
+@@ -25,7 +25,25 @@ MailPartViewers_OBJC_FILES += \
+ UIxMailPartMessageViewer.m \
+ UIxMailPartICalViewer.m \
+ \
+- UIxMailPartICalActions.m
++ UIxMailPartICalActions.m \
++ ../../SoObjects/Mailer/SOGoMailBodyPart.m \
++ ../../SoObjects/Mailer/SOGoHTMLMailBodyPart.m \
++ ../../SoObjects/Mailer/SOGoCalendarMailBodyPart.m \
++ ../../SoObjects/Mailer/SOGoMailAccounts.m \
++ ../../SoObjects/Mailer/SOGoMailBaseObject.m \
++ ../../SoObjects/Mailer/SOGoMailAccount.m \
++ ../../SoObjects/Mailer/SOGoMailNamespace.m \
++ ../../SoObjects/Mailer/SOGoDraftsFolder.m \
++ ../../SoObjects/Mailer/SOGoSentFolder.m \
++ ../../SoObjects/Mailer/SOGoTrashFolder.m \
++ ../../SoObjects/Mailer/SOGoMailFolder.m \
++ ../../SoObjects/Mailer/SOGoDraftObject.m \
++ ../../SoObjects/Mailer/SOGoMailObject.m \
++ ../../SoObjects/Appointments/SOGoEMailAlarmsManager.m \
++ ../../SoObjects/Appointments/SOGoAppointmentObject.m \
++ ../../SoObjects/Appointments/SOGoComponentOccurence.m \
++ ../../SoObjects/Appointments/SOGoAppointmentOccurence.m \
++ ../../SoObjects/Appointments/SOGoCalendarComponent.m
+
+ MailPartViewers_RESOURCE_FILES += \
+ product.plist \
diff --git a/sogo.install b/sogo.install
new file mode 100644
index 000000000000..5b6935f25576
--- /dev/null
+++ b/sogo.install
@@ -0,0 +1,9 @@
+post_install() {
+ useradd -r -d /etc/sogo sogo &>/dev/null
+ chown -R sogo:sogo /etc/sogo
+}
+
+pre_remove() {
+ userdel sogo
+ groupdel sogo
+}
diff --git a/sogo.service b/sogo.service
new file mode 100644
index 000000000000..46120bfc997b
--- /dev/null
+++ b/sogo.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Sogo Daemon
+After=network.target slapd.service memcached.service postfix.service dovecot.service postgresql.service
+
+[Service]
+User=sogo
+RuntimeDirectory=sogo
+ExecStart=/usr/bin/sogod -WOPidFile /var/run/sogo/sogo.pid -WOLogFile "-" -WONoDetach YES
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sogo_configure.patch b/sogo_configure.patch
new file mode 100644
index 000000000000..6bf5414db30d
--- /dev/null
+++ b/sogo_configure.patch
@@ -0,0 +1,14 @@
+251,261c251
+< UNAME=`uname`
+< if [ "X${UNAME}" = "XLinux" ];then
+< UNAME=`uname -m`
+< if [ ${UNAME} = x86_64 -o ${UNAME} = sparc64 -o ${UNAME} = ppc64 ];then
+< cfgwrite "CGS_LIBDIR_NAME:=lib64"
+< else
+< cfgwrite "CGS_LIBDIR_NAME:=lib"
+< fi
+< else
+< cfgwrite "CGS_LIBDIR_NAME:=lib"
+< fi
+---
+> cfgwrite "CGS_LIBDIR_NAME:=lib"