summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2022-12-27 17:34:57 +0100
committerMagnus Boman2022-12-27 17:34:57 +0100
commit1ddb5ba46e180551474154ef9198081370c822ef (patch)
treecd447fbe0a8819cd0db45b463d334443cb52fddc
parent369ad4449233d74f3661cbc1f4615ec0dc92be80 (diff)
downloadaur-1ddb5ba46e180551474154ef9198081370c822ef.tar.gz
upgpkg: godotpcktool-bin 1.8-2
Use versioned license file since it may change (updated years, etc)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f6aa0e8e550..8cd0dc555f2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = godotpcktool-bin
pkgdesc = Standalone tool for extracting and creating Godot .pck files
pkgver = 1.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hhyyrylainen/GodotPckTool
arch = x86_64
license = MIT
@@ -9,8 +9,8 @@ pkgbase = godotpcktool-bin
provides = godotpcktool
conflicts = godotpcktool
source = godotpcktool-1.8::https://github.com/hhyyrylainen/GodotPckTool/releases/download/v1.8/godotpcktool
- source = godotpcktool-bin-LICENSE::https://raw.githubusercontent.com/hhyyrylainen/GodotPckTool/master/LICENSE
+ source = godotpcktool-bin-1.8-LICENSE::https://raw.githubusercontent.com/hhyyrylainen/GodotPckTool/v1.8/LICENSE
sha256sums = 7e3a35c7abe7041b12b9b5f6b51b717bdb0d38ce466a11b05551ed489a717948
- sha256sums = 00de469d52a421d6a9cbfc3d5c23d1fe1c873d72e97762eab794940c193892f7
+ sha256sums = 9713a591001e5fa3d46f2af637b12c35859247a5fe8788abc794fff89f5d5fb8
pkgname = godotpcktool-bin
diff --git a/PKGBUILD b/PKGBUILD
index d0db063101d3..331491a48c30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=godotpcktool-bin
pkgver=1.8
-pkgrel=1
+pkgrel=2
pkgdesc='Standalone tool for extracting and creating Godot .pck files'
arch=(x86_64)
url=https://github.com/hhyyrylainen/GodotPckTool
@@ -11,11 +11,11 @@ depends=(glibc)
provides=(${pkgname%-bin})
conflicts=(${pkgname%-bin})
source=("${pkgname%-bin}-${pkgver}"::"${url}/releases/download/v${pkgver}/${pkgname%-bin}"
- "${pkgname}-LICENSE"::https://raw.githubusercontent.com/hhyyrylainen/GodotPckTool/master/LICENSE)
+ "${pkgname}-${pkgver}-LICENSE"::https://raw.githubusercontent.com/hhyyrylainen/GodotPckTool/v1.8/LICENSE)
sha256sums=('7e3a35c7abe7041b12b9b5f6b51b717bdb0d38ce466a11b05551ed489a717948'
- '00de469d52a421d6a9cbfc3d5c23d1fe1c873d72e97762eab794940c193892f7')
+ '9713a591001e5fa3d46f2af637b12c35859247a5fe8788abc794fff89f5d5fb8')
package() {
install -Dm755 "${pkgname%-bin}-${pkgver}" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${pkgname}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}