summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Fedin2024-03-07 00:12:39 +0400
committerIlya Fedin2024-03-07 00:13:48 +0400
commit1df39df8fdf6290cae6d82f06e8ed25929cc731e (patch)
treeb7ea04b9ffcc0e8dd4123e96c1b18ffb6da81534
parent2c6fd4937d60538ec06d6f31a4bb07119ec4a8ad (diff)
downloadaur-1df39df8fdf6290cae6d82f06e8ed25929cc731e.tar.gz
Fix setting color scheme for applications using KColorSchemeManager
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--qt5ct-shenanigans.patch14
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d281d1bd3143..1810d6c89ee3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5ct-kde
pkgdesc = Qt5 Configuration Utility, patched to work correctly with KDE applications
pkgver = 1.8
- pkgrel = 1
+ pkgrel = 2
url = https://qt5ct.sourceforge.io/
arch = x86_64
license = BSD
@@ -13,6 +13,6 @@ pkgbase = qt5ct-kde
source = https://downloads.sourceforge.net/project/qt5ct/qt5ct-1.8.tar.bz2
source = qt5ct-shenanigans.patch
sha256sums = 23b74054415ea4124328772ef9a6f95083a9b86569e128034a3ff75dfad808e9
- sha256sums = 7f31cc741b386588f5dcc90433d21817ac07ab3a1b419a740a32c05b0087e1e9
+ sha256sums = 63c51ffc1fbad13020fb61358b811fa249b173d41d7b573e9b1374e77a2a64f8
pkgname = qt5ct-kde
diff --git a/PKGBUILD b/PKGBUILD
index 27e130270235..6b1b44602277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=qt5ct-kde
_pkgname=qt5ct
pkgver=1.8
-pkgrel=1
+pkgrel=2
pkgdesc='Qt5 Configuration Utility, patched to work correctly with KDE applications'
arch=(x86_64)
url='https://qt5ct.sourceforge.io/'
@@ -17,7 +17,7 @@ provides=($_pkgname)
source=(https://downloads.sourceforge.net/project/$_pkgname/$_pkgname-$pkgver.tar.bz2
$_pkgname-shenanigans.patch)
sha256sums=('23b74054415ea4124328772ef9a6f95083a9b86569e128034a3ff75dfad808e9'
- '7f31cc741b386588f5dcc90433d21817ac07ab3a1b419a740a32c05b0087e1e9')
+ '63c51ffc1fbad13020fb61358b811fa249b173d41d7b573e9b1374e77a2a64f8')
prepare() {
patch -d $_pkgname-$pkgver -p1 < $_pkgname-shenanigans.patch # The magic
diff --git a/qt5ct-shenanigans.patch b/qt5ct-shenanigans.patch
index 8371e7090e8a..a9a1d0df588f 100644
--- a/qt5ct-shenanigans.patch
+++ b/qt5ct-shenanigans.patch
@@ -1,6 +1,6 @@
Index: qt5ct/CMakeLists.txt
===================================================================
---- qt5ct/CMakeLists.txt (revision 689)
+--- qt5ct/CMakeLists.txt (revision 690)
+++ qt5ct/CMakeLists.txt (working copy)
@@ -27,8 +27,11 @@
@@ -28,7 +28,7 @@ Index: qt5ct/CMakeLists.txt
message(STATUS "Generating translations ...")
Index: qt5ct/src/qt5ct/appearancepage.cpp
===================================================================
---- qt5ct/src/qt5ct/appearancepage.cpp (revision 689)
+--- qt5ct/src/qt5ct/appearancepage.cpp (revision 690)
+++ qt5ct/src/qt5ct/appearancepage.cpp (working copy)
@@ -378,7 +378,7 @@
{
@@ -41,7 +41,7 @@ Index: qt5ct/src/qt5ct/appearancepage.cpp
{
Index: qt5ct/src/qt5ct-common/qt5ct.cpp
===================================================================
---- qt5ct/src/qt5ct-common/qt5ct.cpp (revision 689)
+--- qt5ct/src/qt5ct-common/qt5ct.cpp (revision 690)
+++ qt5ct/src/qt5ct-common/qt5ct.cpp (working copy)
@@ -113,6 +113,7 @@
for(const QString &p : QStandardPaths::standardLocations(QStandardPaths::GenericDataLocation))
@@ -53,7 +53,7 @@ Index: qt5ct/src/qt5ct-common/qt5ct.cpp
paths.removeDuplicates();
Index: qt5ct/src/qt5ct-qtplugin/CMakeLists.txt
===================================================================
---- qt5ct/src/qt5ct-qtplugin/CMakeLists.txt (revision 689)
+--- qt5ct/src/qt5ct-qtplugin/CMakeLists.txt (revision 690)
+++ qt5ct/src/qt5ct-qtplugin/CMakeLists.txt (working copy)
@@ -9,7 +9,7 @@
@@ -66,7 +66,7 @@ Index: qt5ct/src/qt5ct-qtplugin/CMakeLists.txt
endif()
Index: qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp
===================================================================
---- qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (revision 689)
+--- qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (revision 690)
+++ qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (working copy)
@@ -45,6 +45,7 @@
#endif
@@ -148,7 +148,7 @@ Index: qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp
+ QDynamicPropertyChangeEvent *ee = static_cast<QDynamicPropertyChangeEvent*>(e);
+ if(ee->propertyName() == "KDE_COLOR_SCHEME_PATH")
+ {
-+ if(qApp->property("KDE_COLOR_SCHEME_PATH").isNull())
++ if(qApp->property("KDE_COLOR_SCHEME_PATH").toString().isEmpty())
+ {
+ QSettings settings(Qt5CT::configFile(), QSettings::IniFormat);
+ settings.beginGroup("Appearance");
@@ -169,7 +169,7 @@ Index: qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp
+}
Index: qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.h
===================================================================
---- qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.h (revision 689)
+--- qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.h (revision 690)
+++ qt5ct/src/qt5ct-qtplugin/qt5ctplatformtheme.h (working copy)
@@ -87,10 +87,13 @@
//virtual QPixmap fileIconPixmap(const QFileInfo &fileInfo, const QSizeF &size,