summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-09 17:30:56 -0500
committerCarlos Aznarán Laos2022-03-09 17:30:56 -0500
commit1e1750cbdb73f2da121970f4cbaa0b05d2a5d06c (patch)
tree665f2492578c6b22ec5997a0735139a3eac8472b
parentf7b4cb21dcb0e58bdfdca5cadc2f44031fa610f1 (diff)
downloadaur-1e1750cbdb73f2da121970f4cbaa0b05d2a5d06c.tar.gz
Drop python2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD39
2 files changed, 27 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df31933a6dfa..e18f62ee644d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,15 @@
pkgbase = python-seqlearn-git
- pkgdesc = A sequence classification toolkit for Python.
+ pkgdesc = A sequence classification toolkit for Python
pkgver = r89.32d4bfa
pkgrel = 1
- url = http://larsmans.github.io/seqlearn/
- arch = i686
- arch = x86_64
- license = custom: Copyright 2013-2014 Lars Buitinck / University of Amsterdam and contributors
+ url = https://github.com/larsmans/seqlearn
+ arch = any
+ license = custom
+ makedepends = cython
+ makedepends = python-setuptools
makedepends = git
- options = !emptydirs
+ depends = python-scipy
source = git+https://github.com/larsmans/seqlearn.git
- md5sums = SKIP
+ sha512sums = SKIP
pkgname = python-seqlearn-git
- depends = python
- depends = python-numpy>=1.6
- depends = python-scipy>=0.11
- depends = cython>=0.20.2
-
-pkgname = python2-seqlearn-git
- depends = python2
- depends = python2-numpy>=1.6
- depends = python2-scipy>=0.11
- depends = cython2>=0.20.2
-
diff --git a/PKGBUILD b/PKGBUILD
index e6a322db528d..7ce3e0ad6f97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Contributor: Michal Wojdyla < micwoj9292 at gmail dot com >
# Contributor: Ashley Whetter <(firstname) @ awhetter.co.uk>
-
-pkgbase=python-seqlearn-git
-pkgname=('python-seqlearn-git' 'python2-seqlearn-git')
+_base=seqlearn
+pkgname=python-${_base}-git
pkgver=r89.32d4bfa
pkgrel=1
-pkgdesc="A sequence classification toolkit for Python."
-arch=('i686' 'x86_64')
-url="http://larsmans.github.io/seqlearn/"
-license=('custom: Copyright 2013-2014 Lars Buitinck / University of Amsterdam and contributors')
-makedepends=('git')
-options=(!emptydirs)
-source=(git+https://github.com/larsmans/seqlearn.git)
-md5sums=("SKIP")
+pkgdesc="A sequence classification toolkit for Python"
+arch=(any)
+url="https://github.com/larsmans/${_base}"
+license=('custom')
+depends=(python-scipy)
+makedepends=(cython python-setuptools git)
+source=(git+${url}.git)
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/seqlearn"
+ cd ${_base}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package_python-seqlearn-git() {
- depends=('python' 'python-numpy>=1.6' 'python-scipy>=0.11' 'cython>=0.20.2')
- cd "$srcdir/seqlearn"
- python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ cd ${_base}
+ export PYTHONHASHSEED=0
+ python setup.py build_ext --inplace
}
-package_python2-seqlearn-git() {
- depends=('python2' 'python2-numpy>=1.6' 'python2-scipy>=0.11' 'cython2>=0.20.2')
- cd "$srcdir/seqlearn"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+package() {
+ cd ${_base}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}