summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2015-06-09 21:49:14 -0400
committerFrançois Boulogne2015-06-09 21:49:14 -0400
commit1e2f4667ee54c7646547ec689f116779049af3a4 (patch)
treeb14aa3acf80969bf75e6c3fddb782a3eef74e70d
downloadaur-1e2f4667ee54c7646547ec689f116779049af3a4.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4901f8c8d832
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pims
+ pkgdesc = Python Image Sequence: Load video and sequential images
+ pkgver = 0.2.2
+ pkgrel = 2
+ url = https://github.com/soft-matter/pims
+ arch = any
+ license = BSD
+ checkdepends = python-nose
+ makedepends = python-setuptools
+ makedepends = python-scipy
+ makedepends = python-matplotlib
+ makedepends = python-scikit-image
+ depends = python
+ depends = python-tifffile
+ source = https://github.com/soft-matter/pims/archive/v0.2.2.zip
+ md5sums = 6e7aa05d83184af37b094135c025dedf
+
+pkgname = python-pims
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..563b7f4a9322
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Francois Boulogne <fboulogne at april dot org>
+pkgname=python-pims
+pkgver=0.2.2
+pkgrel=2
+pkgdesc="Python Image Sequence: Load video and sequential images"
+url="https://github.com/soft-matter/pims"
+arch=(any)
+license=('BSD')
+depends=('python' 'python-tifffile')
+makedepends=('python-setuptools' 'python-scipy' 'python-matplotlib' 'python-scikit-image')
+checkdepends=('python-nose')
+source=(https://github.com/soft-matter/pims/archive/v$pkgver.zip)
+
+#check() {
+# cd $srcdir/pims-"$pkgver"
+# nosetests3
+#}
+
+package() {
+ cd $srcdir/pims-"$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+md5sums=('6e7aa05d83184af37b094135c025dedf')