summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuint Guvernator2020-10-30 19:43:52 +0100
committerQuint Guvernator2020-10-30 19:46:33 +0100
commit1e312dc3cd97f2373c1785234ab14a93e0749dc1 (patch)
treea4146abb4d41f7488bb976a23f89a82599ab212c
parentd4b7023931d82f85050cb993ce59156c771a4fb4 (diff)
downloadaur-1e312dc3cd97f2373c1785234ab14a93e0749dc1.tar.gz
update patch
-rw-r--r--01-package-path.patch32
-rw-r--r--PKGBUILD2
2 files changed, 20 insertions, 14 deletions
diff --git a/01-package-path.patch b/01-package-path.patch
index 03e17e047070..c4e5a9a3e615 100644
--- a/01-package-path.patch
+++ b/01-package-path.patch
@@ -1,10 +1,8 @@
-diff --git a/HP-15C.tcl b/HP-15C.tcl
-old mode 100644
-new mode 100755
-index 50238bb..209392b
+diff --git a/src/HP-15C.tcl b/src/HP-15C.tcl
+index f9957a3d809e..762d72d9ae9e 100644
--- a/HP-15C.tcl
+++ b/HP-15C.tcl
-@@ -62,7 +62,7 @@ array set APPDATA {
+@@ -63,7 +63,7 @@ array set APPDATA {
}
set APPDATA(SerialNo) "$APPDATA(build)[string map {. {}} $APPDATA(version)]"
@@ -13,20 +11,28 @@ index 50238bb..209392b
set APPDATA(locale) [mclocale]
# Load language according to current locale
-@@ -3252,14 +3253,7 @@ proc help { topic } {
+@@ -3399,22 +3399,7 @@ proc help { topic } {
- switch $topic {
- simulator {
+ global APPDATA HP15 errorInfo
+
+- switch $topic {
+- simulator {
-# Differentiate between running from a starpack or from wish
- if {[info exists ::starkit::topdir]} {
- set helpdir [file dirname $::starkit::topdir]
- } else {
- set helpdir [file dirname $::argv0]
- }
-- if {[string compare $helpdir "."] == 0} {set helpdir [pwd]}
+- if {$helpdir eq "."} {set helpdir [pwd]}
- set helpfile "$helpdir/doc/index.htm"
-+ set helpfile "/usr/share/doc/hp15c/index.htm"
- }
- prgm {
- set helpfile "$HP15(prgmdir)/$HP15(prgmname).htm"
+- }
+- prgm {
+- set helpfile "$HP15(prgmdir)/$HP15(prgmname).htm"
+- }
+- }
+- catch {set helpfile [file nativename [lindex [glob "$helpfile*"] 0]]}
++ set helpfile "/usr/share/doc/hp15c/index.htm"
+
+ if {[string length $HP15(browser)] == 0} {
+ set msg [mc help.nobrowser]
---
diff --git a/PKGBUILD b/PKGBUILD
index 5cf85596eef1..d706a34491a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ source=(
"hp15c.desktop"
)
md5sums=('c3d055f978eb9eba61589fb54204e189'
- '1cce408ad1c6c8458681690e96a02508'
+ 'c63c593bb9cc8083c33d54b87fafd2ad'
'33588adff38833aa1a2957457d4701b3'
'bab776009feb1db971b92649c839ff1f')