summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wiggins2015-06-08 21:37:22 +0100
committerAlex Wiggins2015-06-08 21:37:22 +0100
commit1e36c89e021f94881ef38a36dca1929664a35551 (patch)
treeba9cc7e02b7fe585eb931a1af3487a917cc84705
downloadaur-1e36c89e021f94881ef38a36dca1929664a35551.tar.gz
Initial AUR4 import - version 1.1.1-10
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
-rw-r--r--iscan-plugin-network.install5
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36a3fe335d2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = iscan-plugin-network
+ pkgdesc = Plugin for using Epson scanners with ISCAN over network
+ pkgver = 1.1.1
+ pkgrel = 10
+ url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
+ install = iscan-plugin-network.install
+ arch = i686
+ arch = x86_64
+ license = custom:AVASYSPL
+ depends = iscan
+ source = iscan-network-nt.deb::https://download3.ebz.epson.net/dsc/f/03/00/03/61/60/036fa32e8febc77061170283f84b6b1632949b23/iscan-network-nt_1.1.1-1_i386.deb
+ md5sums = 08b6cd88050151892bc582182cc8a2c0
+
+pkgname = iscan-plugin-network
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf5c72bac4a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alex Wiggins <alex . d . wiggins at gmail . com>
+# Maintainer: bslackr <brendan at vastactive dot com>
+# Contributor: Gianni Vialetto <g dot vialetto at gmail dot com>
+# Contributor: Brian Miller :
+# Contributor: Tom Kuther <gimpel@sonnenkinder.org>
+
+pkgname=iscan-plugin-network
+_pkgintname=iscan-network-nt
+pkgver=1.1.1
+_pkgver=1.1.1-1 # workaround for hyphen in package version
+pkgrel=10
+pkgdesc="Plugin for using Epson scanners with ISCAN over network"
+arch=('i686' 'x86_64')
+url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+license=('custom:AVASYSPL')
+depends=(iscan)
+install=iscan-plugin-network.install
+if [[ ${CARCH} = 'x86_64' ]]; then
+ md5sums=('b9fedf56f04b375df85c7d73d43a922d')
+ source=("iscan-network-nt.deb::https://download3.ebz.epson.net/dsc/f/03/00/03/61/60/41e00501e67a849926adf271afdb4eb258d0b6b8/${_pkgintname}_${_pkgver}_amd64.deb")
+else
+ md5sums=('08b6cd88050151892bc582182cc8a2c0')
+ source=("iscan-network-nt.deb::https://download3.ebz.epson.net/dsc/f/03/00/03/61/60/036fa32e8febc77061170283f84b6b1632949b23/${_pkgintname}_${_pkgver}_i386.deb")
+fi
+
+
+build() {
+cd $srcdir
+bsdtar -xf data.tar.gz
+}
+
+package() {
+cd $srcdir
+cp -R usr $pkgdir
+install -Dm644 usr/share/doc/${_pkgintname}/AVASYSPL.en.txt $pkgdir/usr/share/licenses/${pkgname}/AVASYSPL
+} \ No newline at end of file
diff --git a/iscan-plugin-network.install b/iscan-plugin-network.install
new file mode 100644
index 000000000000..bdcb5938339b
--- /dev/null
+++ b/iscan-plugin-network.install
@@ -0,0 +1,5 @@
+post_install() {
+echo "Remember to set the 'net' conf option in /etc/sane.d/epkowa.conf
+(see an example in /etc/sane.d/epson2.conf)."
+}
+