summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2018-05-25 00:21:39 +0200
committerJoan Figueras2018-05-25 00:21:39 +0200
commit1e6fd3e3e8380c7f0f08323afed3498ed856b0ca (patch)
tree29e14e8454995ee99f7d4dc81aeafa90199fc770
parente02bb9fcf8599a0fccd2327b70b3f3e16c60e6e1 (diff)
downloadaur-1e6fd3e3e8380c7f0f08323afed3498ed856b0ca.tar.gz
Fix build with new ffmpeg
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--libavcodec.patch12
3 files changed, 24 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c54aa6659f6..d064ade9761f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guacamole-server
pkgdesc = Guacamole proxy daemon
pkgver = 0.9.14
- pkgrel = 1
+ pkgrel = 2
url = http://guacamole.sourceforge.net/
install = guacamole-server.install
arch = i686
@@ -33,8 +33,10 @@ pkgbase = guacamole-server
replaces = libguac-client-rdp
source = http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/0.9.14/source/guacamole-server-0.9.14.tar.gz
source = guacd.service
+ source = libavcodec.patch
md5sums = cadc90e526ccf63e01c65017c8881717
md5sums = dfaa29349d2e73af6dac75d6cafbd762
+ md5sums = 6cf58f3148d0ea3f24b4fa362ca79807
pkgname = guacamole-server
diff --git a/PKGBUILD b/PKGBUILD
index 609ec7dd462a..6e53781da4b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=guacamole-server
pkgver=0.9.14
-pkgrel=1
+pkgrel=2
pkgdesc="Guacamole proxy daemon"
arch=('i686' 'x86_64' 'armv7h')
url="http://guacamole.sourceforge.net/"
@@ -21,17 +21,19 @@ optdepends=('libssh: for ssh protocol support'
install=$pkgname.install
source=("http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/${pkgver}/source/${pkgname}-${pkgver}.tar.gz"
- 'guacd.service')
+ 'guacd.service' libavcodec.patch)
md5sums=('cadc90e526ccf63e01c65017c8881717'
- 'dfaa29349d2e73af6dac75d6cafbd762')
+ 'dfaa29349d2e73af6dac75d6cafbd762'
+ '6cf58f3148d0ea3f24b4fa362ca79807')
build() {
cd "$srcdir"/$pkgname-$pkgver
- PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
- CFLAGS+=" -I/usr/include/openssl-1.0" \
- LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl" \
- ./configure --with-openssl --prefix=/usr --sbindir=/usr/bin CPPFLAGS="-Wno-error=pedantic -Wno-error=format-overflow" ## Wno-error=format-overflow added to workaround build in GCC 7.1.1
+ patch -Np1 -i ../libavcodec.patch
+ #PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
+ #CFLAGS+=" -I/usr/include/openssl-1.0" \
+ #LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl" \
+ ./configure --prefix=/usr --sbindir=/usr/bin CPPFLAGS="-Wno-error=pedantic -Wno-error=format-overflow" ## Wno-error=format-overflow added to workaround build in GCC 7.1.1
make
}
diff --git a/libavcodec.patch b/libavcodec.patch
new file mode 100644
index 000000000000..06de5db01873
--- /dev/null
+++ b/libavcodec.patch
@@ -0,0 +1,12 @@
+--- a/src/guacenc/guacenc.c 2018-05-25 00:11:40.315468138 +0200
++++ b/src/guacenc/guacenc.c 2018-05-25 00:11:32.011384353 +0200
+@@ -76,7 +76,9 @@
+ "version " VERSION);
+
+ /* Prepare libavcodec */
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(58, 9, 100)
+ avcodec_register_all();
++#endif
+
+ /* Track number of overall failures */
+ int total_files = argc - optind;