summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhugegameartgd@gmail.com2021-03-21 20:49:22 +0000
committerhugegameartgd@gmail.com2021-03-21 20:49:22 +0000
commit1e94e98e7a39e50d148ed1591e0c93dcfa35fb85 (patch)
tree937fc585bd271c016106b09fe54b62a06fbf8de8
parent00eade28380a40dbce4559d961325ead9ac7dd72 (diff)
downloadaur-1e94e98e7a39e50d148ed1591e0c93dcfa35fb85.tar.gz
fix case sensitive license check
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--license_check_is_case_sensitive-new.patch4
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82799db456b9..ce6bbda4ebfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = msbuild-git
- pkgver = 16.3.0.r3318.g8059ecc7
- pkgrel = 2
+ pkgver = 16.8.0.r4172.gb2c271b4
+ pkgrel = 1
url = https://github.com/mono/msbuild
arch = x86_64
license = MIT
@@ -12,13 +12,11 @@ pkgbase = msbuild-git
source = git+https://github.com/mono/msbuild.git
source = copy_hostfxr.patch
source = fix_bashisms.patch
- source = license_check_is_case_sensitive.patch
- source = fix_dotnet_case.patch
+ source = license_check_is_case_sensitive-new.patch
sha256sums = SKIP
sha256sums = f08615c058771fe740758d9bd2e23e01a52c5d51fab05a15558622e7f7974f22
sha256sums = a13ecb4125c673372d87a3b7d957fc8716a3c3e74cd08e9e354b5dcf170ed453
- sha256sums = 3a12a9c33ad5938e8af24d2985241053602f4efc94a4818a00a17da32ce4aba5
- sha256sums = 69668675a5db978845a48b01b9b30fae07509683deeaef4dd616aba4acb8e2b5
+ sha256sums = SKIP
pkgname = msbuild-git
pkgdesc = Xamarin implementation of the Microsoft build system (Git version)
diff --git a/PKGBUILD b/PKGBUILD
index cbc03477c476..f81907f2bbc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_pkgbase=msbuild
pkgbase=msbuild-git
pkgname=('msbuild-git' 'msbuild-sdkresolver-git')
-pkgver=16.3.0.r3318.g8059ecc7
-pkgrel=2
+pkgver=16.8.0.r4172.gb2c271b4
+pkgrel=1
arch=('x86_64')
url='https://github.com/mono/msbuild'
license=('MIT')
@@ -15,13 +15,11 @@ makedepends=(xmlstarlet unzip dotnet-host dotnet-sdk)
source=('git+https://github.com/mono/msbuild.git'
copy_hostfxr.patch
fix_bashisms.patch
- license_check_is_case_sensitive.patch
- fix_dotnet_case.patch)
+ license_check_is_case_sensitive-new.patch)
sha256sums=('SKIP'
'f08615c058771fe740758d9bd2e23e01a52c5d51fab05a15558622e7f7974f22'
'a13ecb4125c673372d87a3b7d957fc8716a3c3e74cd08e9e354b5dcf170ed453'
- '3a12a9c33ad5938e8af24d2985241053602f4efc94a4818a00a17da32ce4aba5'
- '69668675a5db978845a48b01b9b30fae07509683deeaef4dd616aba4acb8e2b5')
+ 'SKIP')
pkgver() {
local _version _commit
@@ -38,8 +36,9 @@ prepare() {
patch --forward --strip=1 --input="${srcdir}/fix_bashisms.patch"
patch --forward --strip=1 --input="${srcdir}/copy_hostfxr.patch"
- patch --forward --strip=1 --input="${srcdir}/license_check_is_case_sensitive.patch"
- patch --forward --strip=1 --input="${srcdir}/fix_dotnet_case.patch"
+ patch --forward --strip=1 --input="${srcdir}/license_check_is_case_sensitive-new.patch"
+ #patch --forward --strip=1 --input="${srcdir}/license_check_is_case_sensitive.patch"
+ #patch --forward --strip=1 --input="${srcdir}/fix_dotnet_case.patch"
#cp $(pacman -Ql dotnet-host | grep -F libhostfxr.so | cut -d' ' -f2) ./mono/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver/
}
@@ -76,5 +75,5 @@ package_msbuild-sdkresolver-git() {
mkdir -p "${pkgdir}/usr/lib/mono/msbuild/Current/bin/SdkResolvers/"
cp -dr --no-preserve=ownership "${srcdir}/target/usr/lib/mono/msbuild/Current/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver" "${pkgdir}/usr/lib/mono/msbuild/Current/bin/SdkResolvers/"
- cp -dr --no-preserve=ownership $(pacman -Ql dotnet-host | grep -F libhostfxr.so | cut -d' ' -f2) "${pkgdir}/usr/lib/mono/msbuild/Current/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver/"
+ #cp -dr --no-preserve=ownership $(pacman -Ql dotnet-host | grep -F libhostfxr.so | cut -d' ' -f2) "${pkgdir}/usr/lib/mono/msbuild/Current/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver/"
}
diff --git a/license_check_is_case_sensitive-new.patch b/license_check_is_case_sensitive-new.patch
new file mode 100644
index 000000000000..bcd89910ee83
--- /dev/null
+++ b/license_check_is_case_sensitive-new.patch
@@ -0,0 +1,4 @@
+diff --git a/LICENSE b/license
+similarity index 100%
+rename from LICENSE
+rename to license