summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaesim4042017-08-28 11:13:32 +0300
committerCaesim4042017-08-28 11:13:32 +0300
commit1ea18f3fce0701df586e77a91a579b95aacabaff (patch)
tree6490adb97297a5b4b2c8664eee8bfba0787a2b87
parentf36423a7e74553807d973c7254d2e8fe6a5a960b (diff)
downloadaur-1ea18f3fce0701df586e77a91a579b95aacabaff.tar.gz
2.5.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22be6773c22f..40810d2fdd78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-pyjsparser
pkgdesc = Fast JavaScript parser (based on esprima.js)
- pkgver = 2.4.5
+ pkgver = 2.5.2
pkgrel = 1
url = https://github.com/PiotrDabkowski/pyjsparser
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/p/pyjsparser/pyjsparser-2.4.5.tar.gz
- source = https://raw.githubusercontent.com/PiotrDabkowski/Js2Py/master/LICENSE.md
- md5sums = 69a028f632baf7fe79fe2df253cbfd26
- md5sums = faa744092d3fb3314632e815e7c3a560
+ source = https://files.pythonhosted.org/packages/source/p/pyjsparser/pyjsparser-2.5.2.tar.gz
+ source = https://raw.githubusercontent.com/PiotrDabkowski/pyjsparser/master/LICENSE
+ sha256sums = e4a659df3db42a2ff9fbc961eb6d4076a0b945e1aadfc20d48f913ad5dca011d
+ sha256sums = ee43880fad97e97a3d77333915c22766926f1e3dcd0c3e29b112e42246fef4f1
pkgname = python-pyjsparser
diff --git a/PKGBUILD b/PKGBUILD
index 91e253a29ece..8898185d776b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-pyjsparser
_pypiname=${pkgname/python-/}
-pkgver=2.4.5
+pkgver=2.5.2
pkgrel=1
pkgdesc="Fast JavaScript parser (based on esprima.js)"
arch=(any)
@@ -11,15 +11,14 @@ license=(MIT)
depends=(python)
makedepends=(python-setuptools)
source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/PiotrDabkowski/Js2Py/master/LICENSE.md")
-md5sums=("69a028f632baf7fe79fe2df253cbfd26"
- "faa744092d3fb3314632e815e7c3a560")
-
+ "https://raw.githubusercontent.com/PiotrDabkowski/pyjsparser/master/LICENSE")
+sha256sums=('e4a659df3db42a2ff9fbc961eb6d4076a0b945e1aadfc20d48f913ad5dca011d'
+ 'ee43880fad97e97a3d77333915c22766926f1e3dcd0c3e29b112e42246fef4f1')
package() {
cd "${srcdir}"
- install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${_pypiname}-${pkgver}"