summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrabvk2021-12-27 22:04:44 +0500
committercrabvk2021-12-27 22:04:44 +0500
commit1ea2ed631b2e2cb50a9b4f51959e2f8db0d68a96 (patch)
tree893e47ae86b109a41b8762d3c1f7f846a75e2ee2
downloadaur-1ea2ed631b2e2cb50a9b4f51959e2f8db0d68a96.tar.gz
PKGBUILD for bar-protonmail 1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcefcec7c2cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bar-protonmail
+ pkgdesc = Waybar/Polybar module for notifications and unread messages count from ProtonMail
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/crabvk/bar-protonmail
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-pip
+ depends = python-proton-client
+ source = https://github.com/crabvk/bar-protonmail/archive/refs/tags/1.0.0.tar.gz
+ sha512sums = c02311e37e7bbe943733829a5bdd9fe1fc825dcbe57548ce18e4dcf14d53876f20179a8a6df1c506a3dc2b86b679d5b8ef027f2337144cabdfb0174f9e0df380
+
+pkgname = bar-protonmail
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78624be1dcd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Vyacheslav Konovalov <🦀vk@protonmail.com>
+
+pkgname=bar-protonmail
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Waybar/Polybar module for notifications and unread messages count from ProtonMail'
+arch=('any')
+url='https://github.com/crabvk/bar-protonmail'
+license=('MIT')
+depends=('python-proton-client')
+makedepends=('python-build' 'python-pip')
+source=("https://github.com/crabvk/bar-protonmail/archive/refs/tags/$pkgver.tar.gz")
+sha512sums=('c02311e37e7bbe943733829a5bdd9fe1fc825dcbe57548ce18e4dcf14d53876f20179a8a6df1c506a3dc2b86b679d5b8ef027f2337144cabdfb0174f9e0df380')
+
+build() {
+ cd $pkgname-$pkgver
+ python -m build
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps dist/*.whl
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}