summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-10-15 18:33:53 +0200
committerwillemw122023-10-15 18:33:53 +0200
commit1eaca5445089c5ac40ecb45ec7478b6dd29fe3ab (patch)
treedfc3d3aa4b8960464611d22927c01f410bd76be5
parentad0a2b0ae3b60b69a986e914eeff7f0401014aa4 (diff)
downloadaur-1eaca5445089c5ac40ecb45ec7478b6dd29fe3ab.tar.gz
23.70
Cleanup
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 29 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 603785bd3f20..bb30342e6bae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
pkgbase = fotoxx
- pkgdesc = A program for improving image files made with a digital camera, stable version
- pkgver = 23.60
+ pkgdesc = Image editing and collection management program
+ pkgver = 23.70
pkgrel = 1
epoch = 2
- url = http://www.kornelix.net/fotoxx/fotoxx.html
- arch = i686
+ url = https://www.kornelix.net/fotoxx/fotoxx.html
arch = x86_64
license = GPL3
depends = dcraw
depends = gtk3
depends = libchamplain
- depends = perl-image-exiftool>=0.8.6
+ depends = perl-image-exiftool
depends = xdg-utils
- optdepends = rawtherapee: for raw image processing
- optdepends = dvd+rw-tools: for burning CDs,DVDs or BlueRays
- optdepends = hugin: for panorama photos
optdepends = darktable: organize and develop raw images
- optdepends = ghostscript: handle .pdf, .ps or eps-files
- optdepends = vlc: for viewing films
- source = http://www.kornelix.net/downloads/downloads/fotoxx-23.60-source.tar.gz
- sha256sums = ce7eff3682ce8355c5d1f692abe1583dba2c2c7059d47a2a3c341b90051f1a8c
+ optdepends = dvd+rw-tools: for burning CDs,DVDs or Blue-rays
+ optdepends = ghostscript: handle .pdf, .ps or .eps files
+ optdepends = hugin: for panorama photos
+ optdepends = rawtherapee: for raw image processing
+ optdepends = vlc: for viewing video
+ source = https://www.kornelix.net/downloads/downloads/fotoxx-23.70-source.tar.gz
+ sha256sums = 9eea1a0a81d5860d4f8444f78880b93aa082594dfd2e99a137865cad6174daf4
pkgname = fotoxx
diff --git a/PKGBUILD b/PKGBUILD
index bc416093e777..b1f9d97ac0b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=fotoxx
-pkgver=23.60
+pkgver=23.70
pkgrel=1
epoch=2
-pkgdesc="A program for improving image files made with a digital camera, stable version"
-url="http://www.kornelix.net/fotoxx/fotoxx.html"
-arch=('i686' 'x86_64')
-license=('GPL3')
-depends=('dcraw' 'gtk3' 'libchamplain' 'perl-image-exiftool>=0.8.6' 'xdg-utils')
-optdepends=('rawtherapee: for raw image processing'
- 'dvd+rw-tools: for burning CDs,DVDs or BlueRays'
- 'hugin: for panorama photos'
- 'darktable: organize and develop raw images'
- 'ghostscript: handle .pdf, .ps or eps-files'
- 'vlc: for viewing films')
-source=("http://www.kornelix.net/downloads/downloads/$pkgname-$pkgver-source.tar.gz")
-sha256sums=('ce7eff3682ce8355c5d1f692abe1583dba2c2c7059d47a2a3c341b90051f1a8c')
+pkgdesc='Image editing and collection management program'
+url=https://www.kornelix.net/fotoxx/fotoxx.html
+arch=(x86_64)
+license=(GPL3)
+depends=(dcraw gtk3 libchamplain perl-image-exiftool xdg-utils)
+optdepends=('darktable: organize and develop raw images'
+ 'dvd+rw-tools: for burning CDs,DVDs or Blue-rays'
+ 'ghostscript: handle .pdf, .ps or .eps files'
+ 'hugin: for panorama photos'
+ 'rawtherapee: for raw image processing'
+ 'vlc: for viewing video')
+source=("https://www.kornelix.net/downloads/downloads/$pkgname-$pkgver-source.tar.gz")
+sha256sums=('9eea1a0a81d5860d4f8444f78880b93aa082594dfd2e99a137865cad6174daf4')
build() {
- cd $pkgname
- make PREFIX=/usr
+ make -C $pkgname PREFIX=/usr
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" PREFIX=/usr ICONDIR=/usr/share/pixmaps install
+ make -C $pkgname PREFIX=/usr ICONDIR=/usr/share/pixmaps DESTDIR="$pkgdir" install
}