summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Souza2024-01-21 19:13:11 -0300
committerDaniel Souza2024-01-21 19:13:11 -0300
commit1ee7762f1db652c7740b64d5152b853377f6b540 (patch)
tree7feba8f850ce11ab0d03d98f5010efcac7449737
parentb4f978b39913720987470acc4f55869c3fe6496c (diff)
downloadaur-1ee7762f1db652c7740b64d5152b853377f6b540.tar.gz
fix: pkgver()
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 604676840cdb..506cdf6efbd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arbie-git
pkgdesc = Encrypted backup and synchronization tool
- pkgver = v1.3.0.r3.g369fe50
- pkgrel = 4
+ pkgver = v1.3.1.r7.g57fd068
+ pkgrel = 1
url = https://github.com/danisztls/arbie
install = arbie.install
arch = any
@@ -17,6 +17,7 @@ pkgbase = arbie-git
optdepends = pass: standard password manager
optdepends = gopass: improved password manager
provides = arbie
+ conflicts = arbie
source = git+https://github.com/danisztls/arbie.git#branch=main
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3a472cb0a765..cb6951a42517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ _gitauthor="danisztls"
_gitbranch="main"
pkgname="${_pkgname}-git"
-pkgver=v1.3.0.r3.g369fe50
-pkgrel=4
+pkgver=v1.3.1.r7.g57fd068
+pkgrel=1
pkgdesc="Encrypted backup and synchronization tool"
arch=('any')
url="https://github.com/${_gitauthor}/${_pkgname}"
@@ -17,7 +17,7 @@ makedepends=('git' 'make')
optdepends=('pass: standard password manager'
'gopass: improved password manager')
provides=("${_pkgname}")
-conflicts=()
+conflicts=("${_pkgname}")
replaces=()
backup=()
options=()
@@ -36,14 +36,8 @@ pkgver() {
)
}
-prepare() {
- cd "${_pkgname}"
-}
-
-# build() {
-# }
-
package() {
+ cd "$srcdir/${_pkgname}"
make DESTDIR="${pkgdir}/" install
install -vDm 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${_pkgname}"