summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-10-26 17:35:41 +0200
committertytan6522021-10-26 17:35:41 +0200
commit1f30d79ab55cd50a338645f41f6f0c66b1670996 (patch)
treee6cf5d8ea9326b2f7e6a4f8d87b8535c01b09969
parent23401459baf8677085399a175d0d2e0867354cb0 (diff)
downloadaur-1f30d79ab55cd50a338645f41f6f0c66b1670996.tar.gz
build: Cleanup
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4822ebf5b900..cab791ce1ea2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = obs-vnc
pkgdesc = This plugin is a VNC viewer that works as a source in OBS Studio
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://obsproject.com/forum/resources/vnc-source.1000/
arch = i686
arch = x86_64
arch = aarch64
license = GPL2
makedepends = cmake
- depends = obs-studio>=27.0.0
+ depends = obs-studio
depends = libvncserver
source = obs-vnc-0.4.0.tar.gz::https://github.com/norihiro/obs-vnc/archive/0.4.0.tar.gz
sha256sums = c61397314c7cc0518beb7cfcfa89a391039241200fad0e61d01552a3ceceaa57
diff --git a/PKGBUILD b/PKGBUILD
index 7e78d2387690..4575a76427d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
+
pkgname=obs-vnc
pkgver=0.4.0
-_obsver=27.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="This plugin is a VNC viewer that works as a source in OBS Studio"
arch=("i686" "x86_64" "aarch64")
url="https://obsproject.com/forum/resources/vnc-source.1000/"
license=("GPL2")
-depends=("obs-studio>=$_obsver" "libvncserver")
+depends=("obs-studio" "libvncserver")
makedepends=("cmake")
-source=("$pkgname-$pkgver.tar.gz"::"https://github.com/norihiro/obs-vnc/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz"::"https://github.com/norihiro/$pkgname/archive/$pkgver.tar.gz")
sha256sums=("c61397314c7cc0518beb7cfcfa89a391039241200fad0e61d01552a3ceceaa57")
build() {
- cd "$pkgname-$pkgver"
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX='/usr'
- make -C build
+ cd "$pkgname-$pkgver"
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make -C build
}
package() {
- cd "$pkgname-$pkgver"
- make -C build DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"
+ make -C build DESTDIR="$pkgdir/" install
}