summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-11-28 18:04:18 -0500
committerDaniel Moch2018-11-28 18:04:18 -0500
commit1f5751c103919800f73943910aaa18cd4e4b2602 (patch)
tree594985a70938816b2e39ef14f7729f53521f8b0b
parent8101ed734f2a0ed688226152c59e30ba25b17753 (diff)
downloadaur-1f5751c103919800f73943910aaa18cd4e4b2602.tar.gz
upgpkg: nncli-git 0.3.1.r12.g81f6c76-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33e8e12d95a8..94384e3dc1c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = nncli-git
pkgdesc = NextCloud Notes Command Line Interface
- pkgver = 0.3.1.r0.ge6a26e0
+ pkgver = 0.3.1.r12.g81f6c76
pkgrel = 1
- url = https://github.com/djmoch/nncli
+ url = https://nncli.org
arch = any
license = MIT
checkdepends = python-pytest
@@ -21,7 +21,7 @@ pkgbase = nncli-git
depends = python-click
provides = nncli
conflicts = nncli
- source = git+https://github.com/djmoch/nncli?signed
+ source = git+https://git.danielmoch.com/nncli.git?signed
validpgpkeys = 72A97F7072DDCE28058DEF30323C9F1784BDDD43
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 236e70136ccc..614a17c19ecd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Daniel Moch <daniel@danielmoch.com>
_name=nncli
pkgname=nncli-git
-pkgver=0.3.1.r0.ge6a26e0
+pkgver=0.3.1.r12.g81f6c76
pkgrel=1
pkgdesc="NextCloud Notes Command Line Interface"
arch=('any')
-url="https://github.com/djmoch/${_name}"
+url="https://nncli.org"
provides=('nncli')
conflicts=('nncli')
license=('MIT')
@@ -20,25 +20,25 @@ checkdepends=('python-pytest'
'python-pytest-mock'
'python-pylint'
'python-mock')
-source=("git+${url}?signed")
+source=("git+https://git.danielmoch.com/${_name}.git?signed")
validpgpkeys=('72A97F7072DDCE28058DEF30323C9F1784BDDD43')
sha256sums=('SKIP')
pkgver()
{
- cd "${srcdir}/${_name}"
+ cd "${_name}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
check()
{
- cd "${srcdir}/${_name}"
+ cd "${_name}"
python -m pytest
}
build()
{
- cd "${srcdir}/${_name}"
+ cd "${_name}"
flit build
cd "${srcdir}/${_name}/docs"
sphinx-build -M man source build
@@ -46,7 +46,7 @@ build()
package()
{
- cd "${srcdir}/${_name}"
+ cd "${_name}"
_ver=$(cat ${_name}/__init__.py | grep -Eo '[0-9]+\.[0-9]+\.[0-9]+(\.dev[0-9]+)?')
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 docs/build/man/nncli.1 "${pkgdir}/usr/share/man/man1/nncli.1"